Možnosti programu

Servisní program pro aplikace COMPANY MANAGER, PODVOJNÉ ÚČETNICTVÍ, JEDNODUCHÉ ÚČETNICTVÍ, EVIDENCE MAJETKU, MZDY a všechny další databázové aplikace firmy COM-SYS Software.

Program se používá pro servisní činnosti programů jako je např. plánování a dávkové spouštění :

  • mazání zrušených vět,
  • rekonstrukce indexových souborů,
  • servis a rekonstrukce dat ve skladech
  • zálohování a archivace dat - i za provozu aplikace v síti
  • odesílání dat elektronickou poštou

Všechny tyto činnosti lze předem nastavit do nadefinovaných úloh a tyto pak pomocí plánovače úloh ve Windows spouštět ve stanoveném čase.

Možné způsoby použití:

  • Provádět v noci i servis dat, který by jinak při běžném intenzivním provozu síťové aplikace nebyl možný.
  • Naplánovat úlohu, která se spustí po instalaci nových verzí programů a provede kontrolu datových struktur ve více programech, zákaznících i časových obdobích jednou operací.
  • Zálohovat data vybraných programů a zákazníků za běhu programu v síti
  • Archivace spojená s komprimací ušetří diskovou kapacitu a umožní archivovat současně více verzí dat (jména archivů mohou obsahovat datum a čas vytvoření archivu
  • Naplánovat pravidelnou archivaci a odesílání dat z pobočky do centrály e-mailem

Ke komprimaci se používá archivační program WinRar, Ovládání programu

Související témata:


WinRar

WinRar je program pro Windows pro archivaci souborů.

To znamená, že umožňuje více souborů sbalit do jednoho souboru (archivu). Kromě toho, že pak můžeme s těmito soubory manipulovat jako s jedním objektem, poskytují archivační programy další výhody:

  • data zabírají ve sbaleném souboru mnohem méně místa
  • mohou se přitom i zašifrovat, aby je nezneužila nepovolaná osoba
  • výsledný archiv lze rozdělit na díly například na velikost diskety
  • možnost vytváření samorozbalujících (SFX) archivů,

WinRAR je shareware. Kdokoliv jej smí používat ve zkušebním období 40-ti dnů. Po uplynutí této doby nebo dříve, pokud budete chtít WinRARdále používat, se musíte zaregistrovat.

Samorozbalovací - SFX je archiv s připojeným spustitelným modulem, který po spuštění dokáže soubory z archivu extrahovat. K rozbalení SFX archivu není tedy potřeba žádný externí program, stačí jej spustit. I Samorozbalovací archivy mají obvykle příponu .exe jako běžné spustitelné soubory.

Související témata: Možnosti programu


Ovládání programu

Pro výběr, potvrzení volby nebo přesun na položku používáme levé tlačítko myši nebo směrové klávesy ŕß a potvrzení volby klávesou Enter.

Ovládací prvky

  • Tlačítka v pravém horním rohu
  • Posuvníky
  • Tlačítka
  • Textová pole
  • Předvolba
  • Přepínače
  • Obrázková tlačítka
  • Klávesy pro ovládání
  • Ovládací prvek Mřížka
  • Záložky

Související témata: Možnosti programu


Tlačítka v pravém horním rohu

Minimalizovat program do spodní lišty Windows.

Maximalizovat okno na celou obrazovku.

Obnovit původní zobrazení programu.

Tyto tlačítka se střídají maximalizovat - obnovit

Zavřít agendu nebo okno.

Související témata: Ovládání programu


Posuvníky

Posuvníky jsou umístěny po obvodu tabulek např. Seznam úloh, protokol..... Slouží k listování tj. prohlížení v případě, že se tabulka na obrazovku. Ovládají se pomocí myši.

Vertikální posuvníky jsou umístěny vpravo.

Listování v souboru – vertikálně

Značka pro listování po řádcích nahoru

Značka pro listování po řádcích dolů.

Kurzor myši se nastaví na příslušnou značku (v pravém horním rohu nebo v levém dolním rohu) a stisknutím tlačítka myši zajišťuje posouvání řádků nahoru nebo dolů.

Mezi značkami pro listování je značka (obdélníček) [image] , která ukazuje pozici aktuálního záznamu v rámci celého souboru. Když se nastavíme kurzorem myši na tuto značku, stiskneme levé tlačítko myši a se stisknutým tlačítkem přemisťujeme kurzor požadovaným směrem po straně rámečku. Tím způsobem se můžeme také přesunout do požadovaného místa v souboru.

Související témata: Ovládání programu


Tlačítka

Tlačítka jsou prvky, které se používají pro spuštění nějaké volby, ukončení ap..

Tlačítko vybereme pomocí směrových kláves, klávesou TAB nebo myší. Výběr potvrdíme klávesou Enter nebo Mezerník nebo kliknutím levého tlačítka myši.

Např. Tlačítka pro zvolení voleb z hlavní obrazovky.

Tlačítko pro potvrzení např. výběru.

Tlačítko pro ukončení bez výběru.

Související témata: Ovládání programu


Textová pole

Jsou to položky, do kterých se vyplňuje nějaký text, často také datum. Pohyb po polích se provádí směrovými klávesami, klávesou TAB nebo myší. Při vyplňování položky, která je podporována číselníkem, se klávesou F1 nebo pravým tlačítkem myši vyvolá zobrazení číselníku (nápovědy) ve formě menu. Výběr z číselníku se provede pomocí směrových kláves a volba se potvrdí klávesou Enter nebo zruší klávesou Esc nebo tlačítkem Storno.

Např. Název úlohy, pracovní adresář....

Související témata: Ovládání programu


Předvolba

Nastavení předvolby je nezávislé na jiné, tzn. že může být zvoleno několik předvoleb. Předvolba má dvě polohy

  • Ano - okénko zaškrtnuté
  • Ne - okénko prázdné

Přepínání klávesou Enter nebo myší.

Pozor na náhodný výběr, pokud se po položkách pohybujeme klávesou Enter, ne směrovými klávesami nebo klávesou Tab.

Související témata: Ovládání programu


Obrázková tlačítka

Ovládací prvek Obrázková tlačítka se používá se k zakládání, opravě, editaci, rušení řádků nebo pro listování v tabulkách.

Jsou vždy umístěna ve spodní části obrazovky.

Pro snadnější orientaci obsahují tlačítka malou nápovědu. Tato nápověda se zobrazí pokud se nechá kurzor myši pár okamžiků na tlačítku

1) Tlačítka pro posun po větách

  • - na začátek, na první větu v souboru
  • - na předcházející větu
  • - na následující větu
  • - na poslední větu v souboru, na konec

2) Vyhledávání

K vyhledání věty splňující určitou podmínku. Stejná funkce jako klávesa F7 - Hledej.

3) Tisk

Pod tímto obrázkem je tiskové menu

4) Vložení nového řádku

Vložení nové prázdné věty tj. vložení nového řádku. Stejná funkce jako klávesa F6.

V režimu úprav toto tlačítko mění svou funkci na Uložit.

5) Editace řádku

Oprava vybraného řádku. Řádek nebo formulář je otevřen pro editaci. Stejná funkce jako klávesa F4.

V režimu úprav toto tlačítko mění svou funkci na Zrušit změny.

V režimu úprav toto tlačítko mění svou funkci na Zrušit změny.

6) Zrušení nebo obnovení věty

Tímto tlačítkem se aktuální záznam označí jako zrušený, program s ním nepracuje.Pokud je řádka již označená jako zrušená toto tlačítko ji znovu obnoví. Stejná funkce jako klávesa F8.

Vlevo před zrušeným řádkem se objeví černý znak, do řádku se zapíše

Vymazání vět označených jako zrušené se provede

  • přes tlačítko [image] z hlavní obrazovky
  • z menu Tabulka volbou : Mazat zrušené věty.

7) Řazení

Změna pořadí, umožní změnit pořadí vět v databázi, (např. v seznamu úloh). V tabulce se zvolí položka, podle které bude databáze uspořádána. Stejná funkce jako klávesa F3 Pořadí

8) Konec

Tlačítko Konec uloží změny, které uživatel zapsal (vkládání, opravy) a ukončí činnost nebo i agendu. Stejná funkce jako klávesa F2.

Související témata: Ovládání programu


Přepínače

Přepínače se vyskytují vždy ve skupině. Může být nastaven ve skupině vždy jediný. Nastavení vybereme směrovými klávesami a potvrdíme klávesou Enter nebo kliknutím myši.

Související témata: Ovládání programu


Klávesy pro ovládání

Tyto rychlé klávesy jsou využity v celém programu. Používají se k zakládání, opravě, editaci, rušení řádků nebo pro listování. Mají stejnou funkci jako Obrázková tlačítka.

Menu tabulka

Při práci s programem je velmi často zpřístupněno menu Tabulka, které se nachází v horní liště programu. Příkazy tohoto menu se využívají ve všech činnostech při práci s konkrétní databází. Slouží pro ovládání programu pomocí klávesnice.

Značka ^ = klávesa CTRL

Pohyb po jednotlivých větách databáze:

  • ^ HOME - první - na začátek, na první větu
  • ^ PGUP - na předcházející větu
  • ^ PGDN - na následující větu
  • ^ END - na poslední větu v souboru, na konec

F6 - Vložení nové prázdné věty tj. vložení nového řádku

F4 - Oprava vybraného řádku nebo formuláře. Po stisknutí této klávesy je řádek je připraven pro editaci

F2 - Ulož změny. Klávesa F2 uloží změny, které uživatel zapsal (vkládání, opravy) a ukončí činnost.

F8 - Zruš, označení aktuální věty, na které je nastaven kurzor (např. řádku ) jako zrušené. Program s ní nepracuje, ale je možnost ji opět znovu obnovit. Před zrušenou větou je zobrazen znak n a při opětovném použití této klávesy je věta obnovena. Do formuláře se zapíše označení

Fyzické zrušení řádků, dokladů, které jsou označeny jako zrušené se provede volbou Mazat zrušené věty.

Je-li věta označena jako zrušená, zůstává nadále v souboru, nepočítá se s ní, ale je možné ji kdykoliv volbou F8 obnovit.

F3 - Změna pořadí, umožní změnit pořadí vět v databázi. V tabulce se zvolí položka, podle které bude databáze uspořádána.

F7 - Hledání věty s určitou hodnotou položky. Tato volba zobrazí okno, kde se vyplní parametry vyhledávání.

Přehledná tabulka tlačítek a kláves

Tlačítka | Klávesy | Popis
 | CtrlPageUp | Na začátek souboru
 | PageUp | Na předcházející větu
 | PageDown | Na následující větu
 | CtrlPageDown | Na konec souboru
 | F6 | Vložení nové věty
 | F4 | Editace věty
 | Esc | Storno úprav
 | Esc | Konec agendy
 | F2, Esc | Konec editace
 | F8 | Zrušení/Obnovení věty
 | F7 | Hledej hodnotu
 | F3 | Změna pořadí
 | F9 | Uživatelské výpisy
 |  | Tiskové menu

Související témata: Ovládání programu


Ovládací prvek Mřížka

Ovládací prvek mřížka je tabulka, která se používá k zobrazování údajů. Je použita na záložce Seznam - úlohy, Rozpis - tabulky.....

Je to tabulka, kde jsou data uspořádána do sloupců.

V horní části prvku Mřížka jsou nadpisy jednotlivých sloupců. Kliknutím na konkrétní nadpis se tento sloupec setřídí vzestupně. Dvojklikem se setřídí sestupně. Toto lze využít pouze u sloupců, u kterých je nadpis podtržený a tučným písmem. V těchto sloupcích se používá i inkrementální vyhledávání, které slouží k rychlému vyhledání dokladu nebo karty atd. Kurzor musí být ve sloupci, ve kterém potřebujeme rychle vyhledávat, potom stačí postupně na klávesnici psát např. Kód úlohy a program podle zapsaných písmen v příslušném sloupci vyhledává..

Platí např. pro sloupec Kód

Po tabulce se pohybujeme směrovými klávesami a posuvníkem.

V pravé je posuvník, který se používá pro vertikální listování v souboru.

Klávesa ENTER zobrazí vyhledanou úlohu...tj. přepne se do záložky Rozpis

Přesouvání sloupců.

Umístíme kurzor myši na jméno sloupce, který chceme přesouvat. Přesunujeme "uchopený" sloupec (se stisknutým tlačítkem myši) až na požadované místo vpravo nebo vlevo. Uvolníme tlačítko myši.

Změna velikosti sloupce

Umístíme kurzor na čáru, která je na pravém okraji upravovaného sloupce. Posunováním "uchopené čáry" (se stisknutým tlačítkem myši) sloupec zvětšujeme nebo zmenšujeme. Uvolníme tlačítko myši.

Související témata: Ovládání programu


Záložky

V každé agendě se pracuje s několika listy, které se jmenují záložky.

Jejich název je vždy v horní části obrazovky.

Např. u definice jsou záložky: Seznam - úlohy, Rozpis - tabulky, další archivace

Přepínání mezi záložkami:

myší - kliknutím levého tlačítka myši

klávesami - ALT+ podtržené písmeno z názvu. Např. ALT+S, ALT+R, ALT+D

Dole na záložce jsou vždy Obrázková tlačítka, která se používají pro ovládání pomocí myši.

V horním menu je Menu Tabulka, které se používá pro ovládání pomocí klávesnice.

Související témata: Ovládání programu


Číselníky

Tlačítko

Do číselníku je nejprve nutné zapsat aplikace, které jsou na počítači nebo v síti nainstalované. Tj. ty, programy, které bude program SERVIS používat.

Nový řádek klávesa F6 nebo tlačítko [image] .

  • Typ - název programu, např. MANAGER, PODVOJ.......
  • Cesta - zadá se cesta na pevný disk, kde je program nainstalován

Např. C:\COMSYS\MANAGER

C:\PODVOJ.25\

Klávesa F1 na položce Cesta umožní vyhledání domovského adresáře

Výběr disku:

Vývěr adresáře:

Potvrzení výběru adresáře:

  • OP - operační system DOS nebo WINDOWS. Zapíše se v jakém operačním systému je program.

- ukončení bez výběru

Související témata: Ovládání programu


Definice

Tlačítko

Zde se definují jednotlivé úlohy, které bude program SERVIS provádět.

Definice má tři záložky:

  • Seznam - úlohy
  • Rozpis - tabulky
  • Další soubory

Související témata: Číselníky, Servis skladu


Seznam - úlohy

Seznam nadefinovaných servisních úloh.

Na záložce Seznam se nadefinují servisní úlohy. Určí se, které činnosti bude úloha provádět, kam se budou ukládat zálohovaná data, do kterého adresáře se budou ukládat sbalené soubory, zapíší se adresy pro odesílání dat.

Na záložce Rozpis se určí, kterých dat se úloha bude týkat. vyberou se programy, zákazníky i soubory, se kterými bude konkrétní úloha pracovat.

Nová úloha se založí klávesou F6 nebo tlačítkem [image].

  • Kód - zkratka názvu úlohy
  • Název - popis úlohy (50 znaků)

Úlohy mohou obsahovat kombinaci činností, které se nadefinují v tabulce Výběr činností

Je výhodné nadefinovat tyto činnosti pro všechny programy, které firma používá.

M - [image] - Mazat zrušené věty provede hromadné mazání vět, které jsou v souborech označena jako zrušené.

I - [image] - smažou se a vytvoří nové indexové soubory

K - [image] - soubory se budou zálohovat do pracovního adresáře na disku

Pracovní adresář je adresář na disku, do kterého se budou vybrané soubory kopírovat. Pracovní adresář se vybere klávesou F1 na položce Pracovní adresář. Je možné ho také předepsat v Nastavení parametrů. Adresář nemusí existovat, program si ho sám založí. Např. pracovní adresář se jmenuje ZALOHA a je na disku C.

U úlohy Kopie - zálohovat data do pracovního adresáře je možnost zvolit ještě další činnosti.

  • Sbalit zálohované soubory

- znamená, že soubory, které se zálohovaly do pracovního adresáře se zkomprimují a uloží jako sbalený soubor. K tomu je nutné určit adresář, kam se má sbalený soubor uložit a také jméno souboru. Ke komprimaci se používá archivační program pro Windows WinRar

Adresář se vybere na položce Cesta a jméno vytvořeného souboru klávesou F1. Soubor má vždy příponu .rar.

Volba [image] připojí ke jménu souboru datum a čas, kdy byla úloha provedena.

Další volby je možné použít pouze společně s činností

  • Vytvořit samorozbalovací EXE archiv

- tato volba vytvoří zkomprimovaný souborSamorozbalovací archivy mají obvykle příponu .exe jako běžné spustitelné soubory.
Tj. k jeho rozbalení nebude potřeba program WinRar.

  • Move

Nastaví při komprimaci chování WinRaru tak, aby zkopírované soubory v pracovním adresáři po sbalení smazal. (Tj. aby je do archivu přesunul).

Povoleny pouze podadresáře pracovního adresáře. Využití pro odesílání dat. např. z centrály na pobočku. Zapíše se kořenový adresář pro WinRar, aby se nekomprimovaly data s celou cestou a bylo je možné po odeslání např. na pobočku rovnou rozbalit. Cesta pro rozbalení dat se zapíše do komentáře WinRaru.

V záložce Rozpis - tabulky se vyberou soubory, kterých se bude nadefinovaná úloha týkat.

Sbalené soubory je možné také odesílat e-mailem. Odesílání je potom součástí nadefinované úlohy.

- tato volba znamená, že sbalený soubor bude automaticky odeslán e-mailem na zapsanou adresu. Soubor má příponu .rar nebo samorozbalovací s příponou . exe, podle předchozího nastavení.

Adresa musí být nastavená v položce [image]. Pokud bude zapsáno více adres, bude soubor poslán na všechny zapsané e- mailové adresy.

Systém pro odesílání e-mailu.

Tento program podporuje systém:

  • - součást Microsoft Office

  • - sharewarový program pro posílání e-mailů

tlačítko [image] - zobrazí tabulku pro vyplnění údajů potřebných pro odesílání e-mailu pomocí Chilkatmailu

Server - smtp (nutné vyplnit)

Jméno příjemce - jméno adresáta

Jméno odesílatele - jméno od koho je e-mail

Mail odesílatele - e-mailová adresa odesílatele

Vzkaz pro příjemce - doprovodný text

Související témata: WinRar, Definice


Rozpis - tabulky

V této tabulce se nadefinuje, kterých programů, zákazníků a souborů se budou úlohy týkat. Jedna úloha může mít více řádků, protože např. bude zpracovávat data z více programů a z více zákazníků.

Nový řádek se vloží klávesou F6 nebo tlačítkem [image].

Vyplní se položky.

  • Aplikace - název programu. Klávesa F1 nabídne číselník používaných programů.

  • Zákazník - název zákazníka. Klávesa F1 nabídne seznam zákazníků, se kterými se ve vybraném programu pracuje.
  • Typ - typ souborů. Typ souborů, které se budou vybírat při spuštění úlohy.

R - roční soubory - soubory, které jsou v ročním režimu. Např. Vydané faktury, Přijaté faktury, Pokladna....

Z - ostatní soubory zákazníka. Jsou to nadčasové soubory. Např.Adresy, číselníky....

S - Sklad - soubory, které se týkají skladu

A - adresář aplikace - soubory, které jsou uloženy v hlavním adresáři programu. Např. Kurzy cizích měn, slovník...

  • Rok od - do - uvedou se roky, které bude úloha zpracovávat.

Např. - tzn. že se budou zpracovávat tyto roky

- tzn. že se bude vždy zpracovávat aktuální rok a loňský rok.

  • Sklady - pokud je vybrán typ souboru také T, vyberou se sklady. klávesa F1 nabídne nadefinované sklady v konkrétním zákazníkovi.

  • Tabulky - soubory. Klávesa F1 zobrazí soubory podle zadaného typu, ze kterých je možné si vybrat nebo se vyberou všechny.

Související témata: Číselníky, Definice


Servis skladu

Ve skladu je nutné občas provést servisní činnosti. Tyto činnosti také lze nadefinovat do samostatné úlohy nebo lze servis skladu přidat do nějaké úlohy, která pracuje s daty skladu.

Servis skladu - kontrola výdej x příjem

Rekonstrukce indexů - smazání a vytvoření nových indexových souborů ve skladu

Kontrola datumů - vnitřní kontrola datumů. V každém řádku příjemky nebo výdejky musí být stejné datum jako je v hlavičce dokladu (pro tisk statistik).

Přidělit nové ID - vynulovat a přidělit nové ID - vnitřní kontrola mezi příjmem a výdejem. ID je vnitřní číslo zajišťující vazbu mezi příjmem a výdejem.

Opravit zjištěné chyby - opraví chyby ve vnitřní návaznosti výdejů s příjmy

Kontrolovat stav skladu - ve skladech se aktualizuje současný stav, celkový počet zboží a celková skladová cena.

- indexování se bude provádět i v uzavřených skladech

Při přenosu dat např. do pobočky je možné nadefinovat tyto činnosti:

Podle podmínky, která se nastaví, se do dokladů zapíše tisknuto. Např. u přenesených vydaných faktur se u faktur, které mají datum o jeden den menší než aktuální se nastaví tisknuto.

Podle podmínky, která se nastaví, se do dokladů zapíše Zaúčtováno.Např. u přenesených vydaných faktur se podle zadané podmínky nastaví zaúčtováno.

Pokud se přenášení také úhrady faktur tj. soubor Úhrady, je možné zvolit tuto činnost.

Související témata: Definice, Rozpis - tabulky


Další soubory

V této záložce lze nadefinovat zálohu dat, která nesouvisí s aplikacemi firmy ComSys - software.

Např. soubory z Wordu apod.

Je možné tuto zálohu nadefinovat jako samostatnou úlohu nebo přidat do úlohy, která zálohuje data např. nějaké archivování dat.

K tomu je nutné určit adresář, kam se má sbalený soubor uložit a také jméno souboru.

Adresář se vybere na položce Cesta a jméno výstupního archivu klávesou F1. Soubor má vždy příponu .rar.

Volba [image] připojí ke jménu souboru datum a čas, kdy byla úloha provedena.

Parametry pro archivaci

U - aktualizovat a přidat soubory do archivu. Tento příkaz aktualizuje soubory v archivu pouze tehdy, jsou-li starší než soubory vkládané. Přidává i nové soubory.

A - archivace - přidá určené soubory do archivu.

- Sbalit - obsahuje seznam souborů nebo složek ke zpracování. Seznamy jsou textové soubory, obsahující jména souborů a složek, které mají být v příkazu zpracovány.

Např. f:\texty\*.doc

Budou archivovány všechny soubory s příponou .doc z adresáře texty.

Tato tlačítka se použijí pro vyhledání souborů nebo složek do seznamu.

- Kromě souborů - soubory zapsané do této položky nebudou archivovány.

- Komentář archivu -

K archivům RAR lze přidat volitelnou textovou informaci, která se nazývá komentář archivu. Nebo cesta pro rozbalení dat, při přenosu souborů.

- tato volba vytvoří zkomprimovaný soubor, který bude mít příponu .exe. Tj. k jeho rozbalení nebude potřeba program WinRar.

Přepínače pro WinRar - jsou nastaveny automaticky:

r - procházet podsložky

m - nastavení kompresní metody, -m5 - nejlepší kompresní metoda (nejlepší komprese, nejpomalejší)

Související témata: Definice, Seznam - úlohy, Rozpis - tabulky


Příklady úloh

  • Mazání indexových souborů

Po instalaci nových verzí programu se doporučuje provést mazání indexových souborů. Tato úloha se nadefinuje pro všechny programy a všechny zákazníky. Je možné potom tuto úlohu spustit vždy po instalaci nových verzí programu.

V seznamu úloh se nadefinuje Název úlohy a činnosti, které bude úloha obsahovat. Tj. Mazání zrušených vět a vytvoření nových indexových souborů.

V rozpisu se nadefinuje, které programy a zákazníky bude zahrnovat a jakých souborů se bude týkat.

Např. jsou nainstalovány programy COMPANY MANAGER, PODVOJNÉ ÚČETNICTVÍ a EVIDENCE MAJETKU, v každém programu se pracuje se zákazníkem Priklad a Comsys. Pro úlohu se vyberou všechny soubory, v programu Manager také soubory skladu.

  • Zálohování dat

V každé firmě by se mělo provádět pravidelné zálohování dat. Úloha zálohování umožní zálohovat najednou data ze všech programů, které firma používá.

Tato úloha napřed smaže zrušené věty, vytvoří nové indexové soubory a zálohuje zadané soubory z vybraných zákazníků a programů do pracovního adresáře.

  • Archivace dat

Data lze také zálohovat ve zkomprimovaných souborech. Komprimace se provádí WinRarem. Sbalený soubor zabírá na disku méně místa, proto je toto vhodné u velkého objemu dat.

Tato úloha:

- smaže zrušené věty
- vytvoří nové indexové soubory
- zkopíruje nadefinované soubory do pracovního adresáře C:\zaloha
- tyto soubory zkomprimuje a vytvoří sbalený soubor archiv.rar do adresáře C:\ARCHIV
- zkopírované dočasné soubory v pracovním adresáři C:\zaloha smaže

Související témata: Definice, Seznam - úlohy, Rozpis - tabulky


Spuštění úloh

Tímto tlačítkem lze spustit nadefinované úlohy.

Zobrazí se tabulka se všemi úlohami. Vybereme požadovanou úlohu ke zpracování

- spustí se vybraná úloha

- úloha se neprovede

Související témata: Definice


Služby

  • Nastavení parametrů
  • Mazat zrušené
  • Protokol
  • Práva přístupu

Související témata:


Nastavení parametrů

Položky číselníku parametrů

  • Název - název parametru
  • Klíč - název položky v databázi
  • Typ - typ položky
  • Sada -
  • Implicitní - jaká je přednastavená hodnota parametru v programu
  • Aktuální hodnota - nastavená hodnota parametru, tj. kterou má uživatel možnost změnit

Implicitní cesta pro pracovní data - cesta do pracovního adresáře

Obrázek pro screen - obrázek na pozadí programu SERVIS

Pořadové číslo odeslaného e-mailu - zapisuje se poslrdní číslo odeslaného e-mailu

Přepínače WinRaru - přednastavené přepínače pro WinRar

Roční soubory datum posledního zpracování

SENDMAIL - možnost posílání e-mailů Ano/Ne

Související témata: Definice, Služby


Mazat zrušené

Tato činnost provede úplné vymazání zrušených vět, tj. těch, které jsou v souborech označené jako zrušené klávesou F8 nebo tlačítkem [image].

Mazání vět, které jsou označeny jako zrušené lze také provést v každé agendě pomocí stejných kláves.

Související témata: Služby, Definice


Práva přístupu

Jestliže nejsou nastavena práva přístupu, otvírá se program rovnou do hlavní obrazovky.

Jsou-li nastavena práva přístupu pro jednotlivé pracovníky, je umožněn vstup jen těm, kteří mají nějaká práva nastavená.

V menu Práva přístupu má možnost správce programu nastavit práva přístupu pro pracovníky, kteří s programem pracují (zákaz, čtení, vkládání dat). Používá se tam, kde s programem pracuje více osob nebo se program provozuje v síti.

Volba Nastavení práv přístupu má 4 záložky

  • Práva - vlastní nastavení práv přístupu
  • Uživatelé - číselník oprávněných uživatelů
  • Agendy - číselník agend, ve kterých přichází v úvahu nastavení práv přístupu
  • Žurnál - číselník uživatelů, kteří s programem právě pracují

Práva by měl nastavovat správce programu. Nejprve se otevře záložka uživatelů a správce programu zapíše do číselníku uživatelů seznam jednotlivých oprávněných uživatelů programu (Kód uživatele na 5 znaků a jméno uživatele).

- vloží se řádek pro nového uživatele

- zrušení uživatele

- zruší se uživatel a jeho nastavená práva

Záložka Práva zobrazí tabulku práv přístupu. Zde je možno jednotlivým pracovníkům nastavovat práva přístupu:

Nezapomeňte nastavit právo pro samotného správce .

Související témata: Služby, Definice


Protokol

Seznam provedených úloh.

Do protokolu se automaticky zapisují všechny úlohy při jejich spuštění..

  • den - datum, kdy byla úloha provedena
  • čas - kdy byla úloha provedena
  • Akce - název úlohy
  • Text - popis úlohy

Tlačítko [image] zobrazí podrobný zápis o úloze.

Související témata: Služby, Definice


SERVIS

Kontaktní adresa:

Ing. Zdeněk Krejčí, Comsys Software, Neklanova 18, 128 00 Praha 2

zdenek.krejci@comsys.cz
Tel.: 224 911 583

Fax : 224 911 584

Úvodní informace:

Možnosti programu


Obsah

  • Možnosti programu
  • Ovládací prvky
    • Tlačítka v pravém horním rohu
    • Posuvníky
    • Tlačítka
    • Seznam
    • Textová pole
    • Rozbalovací seznam
    • Ovládací prvek Mřížka
    • Zobrazení tabulky
    • Předvolba
    • Předvolba
    • Přepínače
    • Obrázková tlačítka
    • Klávesy pro ovládání
      • Přehledná tabulka kláves
    • Horní menu
      • Menu tabulka
      • F3 – Pořadí
      • F7 - Hledej
      • F9 - Uživatelské výpisy
      • Tlačítka Vyber a Nevyber
  • Instalace programu
    • Instalace programu
    • Přerušení instalace
    • Instalace nové verze programu
    • První spuštění programu
  • Sužby - servis
    • Záloha na disketu
    • Načtení dat z diskety
    • Rekonstrukce indexů
    • Mazat zrušené věty
    • Číselníky
      • Zákazníci programu
      • Země
      • Slovník
      • Řady dokladů
      • Souvztažnosti
      • Střediska
      • Code
      • Pracovníci
      • Běžné účty
      • Způsob platby
    • Ostatní číselníky
    • Nastavení parametrů
    • Práva přístupu
    • Nastav LOGO
    • Změna sériového čísla
    • Protokol změn dokladů
    • Export EBS
    • FV - XML
  • Možnosti tisku
  • Vydané faktury
    • Seznam
    • Položky seznamu
    • Karta - vydaná faktura
      • Vkládání faktury
      • Zrušení faktury
      • Úhrady vydané faktury
    • Rozpis vydané faktury
      • Vkládání řádku rozpisu
      • Zrušení řádku rozpisu
      • Oprava rozpisu
    • Menu Vydané
      • Přepočet částek
      • Úhrady této faktury
      • Faktura -> pokladna
      • Faktura -> výdejka
      • Faktura -> zakázka
      • Zakázka -> rozpis
      • Fakturace z více zakázek
      • Storno
      • Jiná měna, změna kurzu
      • Dobropis
      • Další služby
    • Tisky
      • Dodací list
      • Hromadný tisk faktur
      • Obrat podle odběratelů a zboží
      • Pohledávky
      • Příkaz k úhradě
      • Stvrzenka
      • Vydaná faktura
      • Příjemka - výdejka k faktuře
    • Slevy ve vydaných fakturách
    • Zahraniční vydané faktury
  • Přijaté faktury
    • Seznam
      • Položky seznamu
    • Karta - přijatá faktura
      • Vkládání faktury
      • Zálohová faktura
      • Faktura v cizí měně
      • Menu Přijaté
      • Faktura - Pokladna
      • Vybráno k příkazu
      • Export do ručního příkazu
      • Storno
    • Rozúčtování nákladů
    • Příkaz k úhradě
    • Tiskové výstupy
      • Kurzovní lístek
      • Příkaz k úhradě
      • Závazky
  • Adresy
    • Seznam adres
    • Karta položky adresy
    • Další položky adresy
    • Info o odběrateli
  • Pošta
    • Seznam
    • Karta
    • Tisky
  • Ceník
    • Organizace ceníku
      • Skupiny ceníku MS
    • Seznam
      • Zobrazení tabulky
      • Info o zboží
    • Ceníková karta
      • Založení nového zboží
  • Sklad
    • Evidence skladu
      • Založení skladu
      • Seznam skladů
      • Parametry skladu
    • Příjem - výdej
      • Seznam
        • Položky seznamu
      • Karta
        • Vkládání příjemky_výdejky
        • Zrušení příjemky_výdejky
      • Rozpis
        • Vkládání řádku rozpisu
        • Zrušení řádku rozpisu
        • Oprava řádku rozpisu
    • Servis skladu
    • Sklad tisk
  • Nabídky
  • Zakázky
  • Objednávky
  • Pokladna
    • Seznam
      • Více pokladen
    • Karta - pokladní doklad
    • Nový pokladní doklad
    • Rozpis
    • Pokladní doklad v cizí měně
    • Menu Pokladna
      • Počáteční zůstatek
      • Převod zůstatků z minulého roku
      • Stav pokladny v cizí měně
      • Adresa - Adresář
      • Přepočet stavu pokladny
      • Storno
      • Úhrada faktury
      • Změna čísla dokladu
      • Protokol o dokladu
    • Menu Tisk
      • Pokladní deník
      • Pokladní doklad
      • Stvrzenka
  • Banka
    • Seznam
      • Sloupce Seznamu
      • Více běžných účtů
    • Rozpis bankovního výpisu
    • Nový bankovní výpis
    • Úhrady faktur
      • Úhrada faktury F2
      • Částečná úhrada faktury F3
      • Úhrada - všechny
      • Hromadná úhrada cizích
      • Storno úhrady
  • Výrobní čísla
  • Zaúčtování do účetnictví


Podpora pro CSS

Grafika do projektu: