DMS - DMS

DMS
DMS
Seznam kapitol

Kontaktní adresa:

Comsys Software, Ing. Zdeněk Krejčí, Neklanova 18, 128 00 Praha 2

zdenek.krejci@comsys.cz

www.comsys-sw.cz

Tel. 224 911 583, 224 911 584

Úvodní informace:

Možnosti programu

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023
Nahlásit potíže s kapitolou


Možnosti programu DMS - DMS

DMS
Možnosti programu DMS
Seznam kapitol

Možnosti programu DMS

Dokument management system slouží ke správě elektronických dokumentů a řízení jejich zpracování. Všechny dokumenty jsou spravovány na jednom místě a oprávněné osoby k nim mají přístup i z dalších programů z portfolia Com-Sys Software.

Základní funkce programu:

  • Program pracuje v síti a může tak být používán prakticky neomezeným počtem uživatelů najednou.

  • Umožňuje sdílení dokumentů mezi oprávněnými uživateli na jednom místě, čímž zamezuje existenci různých duplicitních verzí dokumentu mezi uživateli.

  • Kancelář bez papíru - Snadný import elektronických dokumentů a převod papírových dokumentů do digitální podoby. Program umožňuje papírové dokumenty naskenovat nebo snadno vyfotit mobilním telefonem pomocí aplikace Com-Sys Reader (tato aplikace je k dispozici ke stažení zdarma).

  • Systém může sloužit pro více zákazníků (firem).

  • Program lze snadno propojit s dalšími programy z portfolia Com-Sys Software, například z Company Manageru nebo Podvojného účetnictví leze prohlížet dokumenty přiložené k fakturám, pokladním dokladům nebo fotodokumentace.

  • Program umožňuje automatizaci pracovních postupů, například je možné automaticky posílat dokumenty určitého typu konkrétním uživatelům, hlídat termíny atd., což usnadňuje vytváření, úpravy, kontrolu a schvalování všech dokumentů nezbytných pro hladký chod Vaší firmy.

  • Dokumenty lze rozdělit na různé typy, označit oblíbené dokumenty či zobrazit poslední použité nebo ty, které máte ve zpracování po termínu.

  • DMS umožňuje podrobné nastavení práv uživatelů. Některým z nich můžete omezit přístup k některým typům dokumentům.

  • Archivace dokumentů - Pro lepší transparentnost postupů jsou změny dokumentů protokolovány.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


Hlavní obrazovka - DMS

DMS
Hlavní obrazovka
Seznam kapitol

Hlavní obrazovka

Hlavní obrazovka programu:

V horní části je zobrazeno Horní lištové menu

Volby jednotlivých agend:

  • Pořízení - vkládání nových dokumentů do systému. Obsahuje moje koncepty dokumentů, které nevidí ostatní uživatelé programu.

  • Řeším já – přehled dokumentů, ve kterých jsem byl já označen jako řešitel (jmenovitě nebo jako role př. účetní, skladník atp.)

  • Dokumenty - přehled všech dokumentů, ke kterým mám povolená práva přístupu.

  • Oblíbené - přehled dokumentů, které mám nastavené, jako oblíbené, chci je sledovat.

  • Poslední - přehled dokumentů, které jsem upravoval za posledních 30 dní.

  • Po termínu - přehled dokumentů, které mají nastavený termín, do kdy mají být vyřízené a je po tomto datu.

  • Číselníky – nastavení číselníků

  • Servis – Nastavení práv přístupu, parametrů, postupů schvalování dokumentů, import dokladů z Company Manageru, Frutisu atd.

Vypnutí programu

Tlačítko [image] ukončuje program.

Možnosti:

Zpět do programu - vrátí uživatele na hlavní obrazovku.

Odhlásit uživatele - změna přihlášeného uživatele bez ukončení programu.

Změna hesla - každý uživatel má možnost si nastavit svoje heslo a toto kdykoliv změnit. Musí být nastavena práva přístupu, aby se uživatel před nastavením hesla hlásil do programu přihlášením - zadejte jméno (viz. kapitola Práva přístupu).

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


Instalace programu - DMS

DMS
Instalace programu
Seznam kapitol
Instalace programu

Program DMS si po objednání nové verze u naší firmy jednoduše nainstalujete z našich webových stránek www.comsys-sw.cz. Veškerou dokumentaci je také možné stáhnout z webových stránek.

Programovací jazyk - Visual FoxPro 9.0

  • Instalace programu

  • Registrace

  • První spuštění

Související témata

Instalace programu | Registrace | První spuštění programu |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023


Instalace programu - DMS

DMS
Instalace programu
Seznam kapitol

Instalace programu

Instalace nového programu nebo instalace nové verze (upgrade) probíhá obdobně.

Stažení a instalace z Webu

Po objednání nové verze u naší firmy je možné se dohodnout, že si nainstalujete novou verzi z našich webových stránek. www.comsys-sw.cz. Nejprve je nutné se přihlásit jako uživatel. V levém sloupci na hlavní obrazovce webových stránek.

Naši zákazníci, kteří jsou registrováni v databázi webového serveru, mají možnost se na tomto místě přihlásit do systému. V souladu s přidělenými právy jsou jim po úspěšném přihlášení zpřístupněny další informace a je jim umožněno i stahování informačních a programových souborů, které nejsou běžně dostupné.

Pokud jste zapomněl(a) svoje heslo, vyplňte pouze svoje uživatelské jméno, údaj o hesle nevyplňujte, ale uveďte Vaši emailovou adresu. Ta musí být ovšem shodná s emailovou adresou, která je uvedena ve Vašem registračním záznamu. Po aktivaci tlačítka [image] Vám bude na uvedenou email adresu obratem zasláno Vaše nové heslo.

V případě, že nejste zaregistrováni, musíte se [image] . Viz. kapitola Registrace.

Novou verzi programu instaluje přihlášený uživatel z nabídky [image] Aktualizace - která zobrazí přihlášenému uživateli webu seznam programů, které může stáhnout.

Při instalaci nového programu Docházka je třeba nainstalovat 2 soubory - CBD9.exe a Doch_upg.exe

  • CDB9.exe - jsou knihovny pro aplikace Windows.
  • Doch_upg.exe - je instalační soubor programu Podvojné účetnictví.

Soubor CDB9.exe je nejčastěji uložen v adresáři Servis. Po jeho spuštění se vyplní pouze jméno uživatele.

Po spuštění souboru Doch_upg.exe se provede instalace programu Docházka nebo jeho nové verze.

Program při instalaci nové verze nesmí mít žádný uživatel otevřený ani na jiném počítači.

Spuštění instalace:

Tlačítko [image] nainstaluje program standardně do složky C:DOCHAZKA. Na disku C se vytvoří složka PODVOJ, do které se provede instalace programu. Implicitně se nabízí disk C:\DOCHAZKA. Můžete ale změnit disk.

Pokud souhlasíte s cílovým adresářem, stiskněte [image].

Jestliže chcete program nainstalovat do jiného adresáře, je třeba pomocí tlačítka [image] změnit cílovou složku.

Instalaci je možné přerušit tlačítkem [image].

Tímto způsobem se instalují všechny nové verze programu.

Při instalaci nové verze programu (upgrade) se instaluje pouze soubor Dms_upg.exe

Související témata

Registrace | První spuštění programu
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023


Registrace - DMS

DMS
Registrace
Seznam kapitol

Registrace

V případě, že nejste zaregistrováni, vyplňte na [image] položky formuláře označené *. Z údajů "Název firmy" a "Jméno a příjmení" musí být vyplněn alespoň jeden!

Uvádějte výhradně fakturační adresu!

Registrace se provede tlačítkem

Důležité je uživatelské jméno. Zapamatujte si jak je napsané, záleží na velkých a malých písmenech.

Pokud byla registrace úspěšná, na uvedený e-mail bude obratem zasláno přístupové heslo. Potom provedete [image] :

  • uživatelské jméno
  • heslo

Nabídka [image] Aktualizace - zobrazí přihlášenému uživateli webu seznam programů, které může stáhnout.

Související témata

Instalace programu
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 02.03.2020


První spuštění programu - DMS

DMS
První spuštění programu
Seznam kapitol

První spuštění programu

Spuštění programu Docházka se provede příkazem Dms.exe v adresáři DMS.

Na ploše Windows se vytvoří ikona pro spouštění programu. Program DMS se potom otvírá pomocí této ikony.

Po spuštění programu se provede Zavedení firmy.

Příručka uživatele

Ve složce Dokumenty je elektronická nápověda – příručka programu dochazka.chm.

Aktuální příručku je také možné prohlížet on-line [image] nebo si ji stáhnout z webových stránek naší firmy www.comsys-sw.cz.

Vícenásobné spuštění programu

Je povoleno vícenásobné spuštění programu Docházka. To znamená, že je možno mít program spuštěn na ploše několikrát a v každém okně být nastaven například v jiném zákazníkovi nebo jiném pracovním období a současně tato data zpracovávat.
Při vícenásobném spuštění programu platí stejná omezení, jako když pracuje několik uživatelů v síti. Tj. nelze provádět některé činnosti jako například mazání zrušených vět. Program v takové situaci ohlásí, že s daty pracuje jiný uživatel.

Související témata

Instalace programu | Zavedení firmy
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 31.05.2023


Ovládací prvky - DMS

DMS
Ovládací prvky
Seznam kapitol
Ovládací prvky

V dalších kapitolách jsou popsány ovládací prvky, které používá program Docházka.

Seznam ovládacích prvků použitých v programu:

  • Tlačítka v pravém horním rohu

  • Posuvníky

  • Tlačítka

  • Seznam

  • Textová pole

  • Rozbalovací seznam

  • Ovládací prvek Mřížka

  • Předvolba

  • Přepínače

  • Obrázková tlačítka

  • Klávesy pro ovládání

  • Horní menu

  • Záložky

Pro výběr, potvrzení volby nebo přesun na položku používáme levé tlačítko myši nebo směrové klávesy a a poté potvrzení volby klávesou Enter.

Související témata

Tlačítka v pravém horním rohu | Posuvníky | Tlačítka v programu | Textová pole | Tabulka | Předvolba | Přepínače | Klávesy pro ovládání | Záložky |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 03.01.2022


Tlačítka v pravém horním rohu - DMS

DMS
Tlačítka v pravém horním rohu
Seznam kapitol

Tlačítka v pravém horním rohu

V pravém horním rohu programu jsou tlačítka, pomocí kterých se ovládá okno programu.

Minimalizovat program do spodní lišty Windows.

Maximalizovat okno na celou obrazovku.

Obnovit původní zobrazení programu.

Tato 2 tlačítka se střídají maximalizovat nebo obnovit.

Zavřít agendu nebo okno.

Ukončení programu

Pro ukončení celého programu lze použít pouze tlačítko Konec z hlavní obrazovky programu.

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 20.11.2020


Horní lištové menu - DMS

DMS
Horní lištové menu
Seznam kapitol
Horní lištové menu

Horní lištové menu umožňuje práci v jednotlivých agendách programu. Položky menu, jejichž písmo je šedé, momentálně nelze vybrat.

  • Soubor - toto menu je zpřístupněno pouze při úpravě reportu.

  • Úpravy - je možné používat při vyplňování položek. Umožňuje především označí části textu, jeho zkopírování do střižny (clipboard) a po přesunu jeho přilepení na novém místě. Pro výběr textu slouží klávesa Shift+směrové klávesy. Vybrat lze několik slov, řádek... vybraný text je zobrazen modře.
    Ctrl+X - zapamatování textu
    Ctrl+C - kopírování textu do clipboardu
    Ctrl+V - vložení textu na jiné místo
    Ctrl+A - vyber všechno
    Ctrl+Z - zpět změny, zrušit poslední opravu

  • Zobraz Ctrl+F1- přepínání mezi dvěma okny

  • Nápověda

  • Menu Služby

  • Menu tabulka

  • Číselníky

V jednotlivých agendách jsou přístupná další menu, související přímo s konkrétní agendou.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Menu tabulka - DMS

DMS
Menu tabulka
Seznam kapitol

Menu tabulka

Při práci s programem je často zpřístupněno menu Tabulka, které se nachází v horní liště programu. Příkazy tohoto menu se využívají ve všech činnostech při práci s konkrétní databází. Slouží pro ovládání programu pomocí klávesnice.

Význam jednotlivých kláves je vysvětlen v kap. Klávesy pro ovládání - F2, F4, F6, F8, F1, ALT+M Pořadí - F3, Hledej - F7, Uživatelské výpisy F9.

Vyber doklady od -do

Hromadný výběr dokladů pro uživatelské výpisy.

Tlačítka Vyber a Nevyber v uživatelských výpisech.

  • Tlačítko Vyber - vybere všechny věty, které splňují podmínky zadané v rámečku. položka Vyber = "T".
  • Tlačítko Nevyber - nevybere všechny věty, které splňují zadané podmínky. Položka vyber = "F".

Velikost okna

Uložení velikosti okna. Pomocí myši je možné zvětšit okno na obrazovce.

Volbou Ulož se tato velikost okna uloží. Při opakovaném otevření agendy bude zobrazena uživatelem zvolená velikost okna.

Návrat k originálu - návrat k původní velikosti okna.

Tlačítko - [image] - velikost okna

Zobrazení tabulky

Tabulka je zobrazení uspořádané do sloupců. Je použité např. ve všech záložkách Seznam v jednotlivých agendách.

V seznamu má živatel možnost si nadefinovat, které sloupce se v tabulce budou zobrazovat - Zobrazení tabulky.

Tlačítko - [image] - zobrazení (nastavení) tabulky.

Velikost písma pro číselníky

Je možné změnit (zvětšit) velikost písma v číselnících.

Nová velikost písma se projeví až při příštím spuštění číselníku.

Protokol o řádku

Pokud je nastaveno v parametrech podrobné protokolování dokladů, zobrazují se změny v konkrétním dokladu. Na kartě nebo v rozpisu. Viz kapitola Protokol o řádku.

Seznam - Karta - Rozpis

Přepínání pomocí kláves mezi záložkami - Záložky.

Seznam ALT+S
Karta ALT+K
Rozpis ALT+R

Rychlost inkrementálního gridu

Zadává se v sekundách prodleva pro stisk po sobě jdoucích kláves pro inkrementální vyhledávání např. v seznamu.

Pořadí položek

V jednotlivých agendách je možné nastavit pořadí položek, které jsou přístupné k editaci. Využití například v agendě Adresy. V seznamech se využívá Pořadí sloupců - Zobrazení tabulky.

Uživatel si pomocí myši přesune položky do požadovaného pořadí. První položka, na které je kurzor při otevření tabulky musí zůstat. Např. v tomto případě období, ostatní lze přesunovat.

Kopíruj do schránky

Možnost kopírovat z programu okno nebo jeho část do souboru pro další použití

  • Kopíruj okno do schránky Ctrl+F9

  • Kopíruj část okna Alt+F9

Kopíruj okno do schránky - v programu, kdekoliv je na obrazovce nějaké okno a přístupno menu Tabulka je možnost toto okno zkopírovat do schránky a kdekoliv jinde mimo program ho vložit.klávesami Ctrl+V. Například do e-mailu do textového dokumentu.

Kopíruj část okna - obdobná činnost ale je možné zkopírovat pouze část okna.

Zákaz vybraných položek

Při pořizování dokladů, vydané faktury, přijaté faktury zakázky, nabídky, objednávky a další, si může uživatel nastavit, které položky na kartě dokladu bude používat. Položky, které nepotřebuje vyplňovat, může zakázat a nebude do nich vstupovat. V menu Tabulka Nastavit zakázané položky.

Nastavuje se samostatně v každé agendě. Uživatel musí být na záložce, kterou potřebuje upravit.

Mazat zrušené věty

Tato činnost provede úplné vymazání zrušených vět, tj. těch, které jsou v souborech označené jako zrušené klávesou F8 nebo tlačítkem [image].

Při práci v síti je možné tuto činnost provést pouze v případě, že ze souborem nepracuje jiný uživatel.

Mazání vět, které jsou označeny jako zrušené lze také provést v každé agendě. Menu tabulka - Mazat zrušené věty ALT+M.

Obrazovka pro hromadné mazání zrušených vět.

Na obrazovce jsou vypsány všechny soubory,se kterými program pracuje.

Jednotlivé sloupce:

Popis - popis souboru
Tabulka - jméno souboru v agendě
Agenda - agenda, ve které je soubor
Stav - vypisuje se automaticky jestli je soubor vybrán k mazání nebo informace, že v souboru nejsou vybrány věty k mazání

Na obrazovce jsou zobrazeny všechny datové soubory (tabulky), se kterými program pracuje. Z nich je možné vybrat ty, ve kterých proběhne mazání zrušených vět

- Označí se soubor (tabulka) na pozici kurzoru. K této volbě lze použít klávesu Enter. Vybraný soubor je zvýrazněný. Opakovaným stiskem se soubor (tabulka) odznačí.

- Tímto tlačítkem se označí se všechny soubory (tabulky). Použije se v případě, že potřebujeme provést mazání zrušených vět ve všech souborech od aktuálního zákazníka tj. od firmy, se kterou právě pracujeme. Neoznačí se pouze soubor Zákazník, který obsahuje nastavení parametrů pro jednotlivé zákazníky a je společný.

- Tímto tlačítkem se z tabulky vybere agenda, ve které proběhne mazání zrušených vět a poté se hromadně označí všechny soubory (tabulky), které tato agenda používá. Např. Deník

- Odznačí se všechny soubory (tabulky), tj. není vybrána žádná tabulka (soubor).

V případě, že se pravidelně provádí mazání zrušených vět touto činností, je možné si vybrané soubory, ve kterých se mazání provádí uložit pro příští použití tlačítkem [image].

- provede se mazání zrušených vět (řádků) ve vybraných souborech.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 31.05.2023


F3 - Pořadí - DMS

DMS
F3 - Pořadí
Seznam kapitol

F3 - Pořadí

Změna setřídění, umožní změnit pořadí vět v tabulce. Např. ve vydaných nebo přijatých fakturách.

Po stisknutí klávesy F3 se zobrazí tabulka s položkami, podle kterých lze databázi uspořádat.

V tabulce se zvolí položka, podle které bude databáze uspořádána.

OK – potvrzení a uspořádání

Storno – ukončení bez změny

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 19.11.2020


F7 - Hledej - DMS

DMS
F7 - Hledej
Seznam kapitol

F7 - Hledej

Činnost Hledej spustíte klávesou F7 nebo tlačítkem [image] a pracuje s tabulkou, ve které jste funkci spustili.

Činnost se používá k:

  • K vyhledání věty splňující určitou podmínku.
  • K vybrání vět (nastavení filtru), které splňují určitou podmínku.

V řádcích se mohou zapisovat podmínky pro výběr řádků. Zapsané podmínky platí všechny současně ( [image]) nebo alespoň jedna z nich ( [image]).

Vyplnění podmínek

V řádku každé podmínky se vyplňují 3 pole:

  • Položka, pro kterou se bude zapisovat podmínka.

    Kliknutím myši nebo klávesou mezerník otevřete rozbalovací seznamu, kde se vybere položka, která musí splňovat určitou podmínku.

    Při výběru položky naleznete za jejím názvem informace o jejích vlastnostech (jak vyplňovat pole hodnota).

    Př. ZAPLACENO, D – pole zaplaceno obsahuje datum (úhrady)

    CASTKA, N(12,2) – pole částka obsahuje číslo s max. počtem 12 číslic před a 2 za desetinnou čárkou

    TEXT, C(30) – pole tex obsahuje řetězec o maximálním počtu 30 znaků

    REZERVACE, L – pole rezervace obsahuje logickou hodnotu ANO/NE

  • Operátor podmínka, relační znaménko.
    Význam jednotlivých relačních znamének:

    IN - položka je obsažena v seznamu, který následuje, jednotlivé hodnoty jsou odděleny čárkami, např. hledání dvou celkových částek ve fakturách

    od;do - položka je mezi hodnotami od – do, jednotlivé hodnoty jsou odděleny čárkami, např. hledání částek ve fakturách v intervalu od - do

  • Hodnota zapíše se hledaná hodnota.

V jednotlivých polích otevřete výběr kliknutím myši do pole nebo klávesou mezerník.

Tlačítka

- vymaže všechny vyplněné podmínky

- zruší jednotlivý řádek vyplněné podmínky

- vyhledávání chyb

- ukáže náhled řádků tabulky, které splňují vyplněné podmínky

- slouží k ukládání nastavení funkce hledej nebo načtení uloženého nastavení

Otevřou se volby:

Nastav jako implicitní – uloží nastavení podmínek a, když spustíte F7/ [image], předvyplní toto uložené nastavení.

- nastaví filtr podle vyplněných podmínek

- vypne nastavený filtr

- ukončí funkci hledej bez nastavení filtru

Příklady

Př.1) V agendě Vydané faktury je potřeba vyhledat všechny faktury, které mají částku větší nebo rovnou 10 000 Kč (pole CASTKA >= 10000), souvztažnost 3 (pole VZTAH = 3) a současně nejsou zaplacené (pole ZAPLACENO je prázdné).

Př.2) V agendě Adresy vybereme ty, které mají zaškrtnuto VÝROBCE a jsou z Brna (pole MESTO).

Př.3) V agendě Přijaté faktury vybereme ty, které mají v textu ubytování nebo souvztažnost 5 (pole VZTAH).

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


F9 - Uživatelské výpisy - DMS

DMS
F9 - Uživatelské výpisy
Seznam kapitol
F9 - Uživatelské výpisy

Pro tisk vybraných informací z libovolné tabulky slouží univerzální program Uživatelské výpisy.

Tabulku (soubor) si můžeme představit jako rozsáhlou tabulku, kde jedna věta je řádek tabulky a jedna položka je jeden sloupec tabulky.
Uživatelské výpisy nám umožní vybrat, které řádky a sloupce tabulky se budou tisknout.

Obrázkové tlačítko

Je možné přepínat mezi dvěma režimy:

  1. režim Tisk - nabídne tisky definované a uložené v agendě, odkud uživatelské výpisy otevřete.

  2. režim Návrh - umožňuje definovat vlastní uživatelské výpisy.

Volba výstupního zařízení

Sestavu, kterou jsme si navrhli v uživatelských výpisech můžeme vytisknout.

Použití je stejné jako v celém programu. Viz. kapitola Volba výstupního zařízení.

Tlačítko [image] vypne formulář Uživatelské výpisy.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Uživatelské výpisy - režim Tisk - DMS

DMS
Uživatelské výpisy - režim Tisk
Seznam kapitol

Uživatelské výpisy - režim Tisk

Režim tisk nabídne tisky definované a uložené v agendě, odkud uživatelské výpisy otevřete.

Můžete je pak rovnou tisknout nemusíte je vyvolávat tlačítkem [image] viz Uložení nastavení pro tiskové výstupy.

Volba výstupního zařízení

Sestavu, kterou jsme si navrhli v uživatelských výpisech můžeme vytisknout.

Použití je stejné jako v celém programu. Viz. kapitola Volba výstupního zařízení.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Uživatelské výpisy - režim Návrh - DMS

DMS
Uživatelské výpisy - režim Návrh
Seznam kapitol
Uživatelské výpisy - režim Návrh

Režim Návrh umožňuje definovat vlastní uživatelské výpisy a vytvářet vlastní reporty (tisky). Návrh má několik záložek:

  • Select
  • Položky
  • Podmínky - Filtr
  • Formát Výstupu

Do položky Nadpis se zapíše pojmenování tisku, které se bude tisknout na každou stránku výpisu. Implicitně je zapsáno jméno tabulky.

Uložení definice uživatelského výpisu

To umožní snáze udržovat definice výpisů a také sdílet. Předávat a přebírat definice výpisů například E-mailem.

- pod názvem lze uložit nastavenou definici pro opakované použití

- vybereme z uložených definic uživatelských výstupů

- prohlížení a rušení definice výpisů

- ukáže se formulář se SQL zápisem navoleného uživatelského výpisu.

Př.

- export definice aktuálního výpisu do XML

- import definice výpisu z XML

Uložení, načtení a úpravy uloženého uživatelského výpisu také tlačítko [image] viz kapitola Uložení nastavení pro tiskové výstupy.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Uživatelské výpisy - Select - SQL - DMS

DMS
Uživatelské výpisy - Select - SQL
Seznam kapitol

Uživatelské výpisy - Select - SQL

Pokud přepnete režim Tisk na režim Návrh, otevře se formulář na záložce Select SQL, ve kterém je vybraný tisk přepsaný v dotazovacím jazyce SQL.

Pokud chcete pole vyčistit a definovat úplně nový uživatelský výpis, pak použijte tlačítko [image].

Klávesa F1 v poli pro zadání SQL dotazu se vyplní dotaz podle zadání v záložkách Položky a FILTR.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Uživatelské výpisy - Položky - DMS

DMS
Uživatelské výpisy - Položky
Seznam kapitol

Uživatelské výpisy - Položky

Záložka Uživatelských výpisův režimu Návrh slouží k výběru tabulky a vybraných položek z ní, které chceme zobrazit/vytisknout.

Slouží pro tisk vybraných informací z libovolné tabulky.

Jedna věta tabulky (např. jedna faktura, jedna adresa z adresáře……) je řádek a jedna položka (např. datum vystavení, celková částka, firma….) je jeden sloupec tabulky. Uživatelské výpisy nám umožní vybrat, které řádky a sloupce tabulky se budou tisknout.

Tlačítko [image] - uloží seznam vybraných polí do schránky, můžete je pak vložit do záložky Uživatelské výpisy - Select - SQL (Ctrl + V).

Například:
Z agendy Adresy vytisknout seznam firem, které mají sídlo v Praze.

Výběr tabulky

Nejprve vybereme, ze které tabulky chceme tisknout.

Kliknutím na šipku se rozbalí seznam pro výběr tabulky - Adresy.

Volba pořadí řádků

Pořadí, ve kterém budou vytisknuty jednotlivé řádky tabulky. Je možné určit pořadí, ve kterém budou tištěny jednotlivé řádky.

Kliknutím na šipku se rozbalí seznam pro výběr pořadí. Pořadí "Záznam" znamená, že řádky budou tištěny v pořadí podle čísla záznamu, tedy tak, jak byly v historii zapisovány.

Například:
Firma - Seznam adres bude vytištěn v pořadí podle firmy.

Výběr položek pro tisk

Bez výběru položek pro tisk, by byly do výpisu vytištěny všechny položky, které tabulka obsahuje. Výpis by obsahoval mnoho sloupců.

V levém sloupci jsou zobrazeny všechny položky tabulky – nevybrané položky.
V pravém sloupci ty, které budou vybrány pro tisk – vybrané položky.

- nevybrané položky se setřídí podle abecedy.

Mezi rámečky jsou umístěna tlačítka, která umožní přesouvat položky z levého do pravého rámečku a zpět tj. umožní nám vybírat položky pro tisk.

- zařadí položku, na které je kurzor, z nevybraných do vybraných položek

- zařadit do vybraných vše

- vyřadí položku, na které je kurzor, z vybraných do nevybraných

- vyřadit z vybraných vše

- zařadí do vybraných položek pouze ty sloupce dané tabulky, které obsahují nějaký záznam

Po použití tlačítka se tyto položky uloží do schránky a klávesou CTRL+V je můžeme vytisknout.
Např:
Adresy.FIRMA, Adresy.MESTO, Adresy.ULICE, Adresy.PSC, Adresy.MIS_URCENI

Před každou položku se v tomto případě tiskne prefix Adresy - tzn. položky byly vybrány z tabulky Adresy.

Volba pořadí - sloupců

Vybrané položky pro tisk v tabulce uživatelské výpisy tvoří sloupce této tabulky. Je možné sestavit pořadí sloupců.

Volbu pořadí položek – sloupců lze provést přetažením myší. Kurzor myši umístit na značku před položkou [image] (v okně vybrané položky). Stisknout levé tlačítko myši a táhnout na požadované místo.

Takto bychom vytiskli telefonní seznam pro všechny firmy, které jsou v adresáři.

Je ještě možnost vybrat jen některé firmy tzn. vybrat řádky tabulky. Vybereme pouze firmy, které mají sídlo v Praze.

Zobrazené položky, součty

V Uživatelských výpisech, režimu Návrh na záložce Položky naleznete pole Netisknout v detailu položky a Nepočítat součty pro číselné položky.

- F1 nabídne na výběr sloupce z výběru obsahující čísla. U vybraných sloupců [image] se nebude tisknout součet. Například nemá smysl sčítat čísla dokladů, zakázek, souvztažností atp. Díky tomu se zúží sloupce, které nesčítám (upraví se šířka sloupců).

- F1 nabídne všechny sloupce z Výběru, které zůstanou v datech, ale vybrané sloupce [image] se nebudou tisknout. V datech mohou být potřeba například kvůli tomu, že jsou obsaženy ve výpočtu kalkulovaného sloupce nebo kvůli seřazení (př. report je seřazen a posčítán po firmách, ale název firmy pak už nemusí být znovu zapsán v každém řádku reportu).

Kalkulované sloupce

Pro všechny verze aplikací pro Windows byla zpracována nová verze uživatelských výstupů pro zkušené uživatele. Umožňuje definovat příkaz výběr z jedné i více tabulek pomocí příkazu SQL, včetně kalkulovaných sloupců, souhrnů a složitějších výběrových podmínek. Výstup je možné tisknout na obrazovku, tiskárnu, do řady různých formátů (DOC, XLS, PDF …). Export do excelu byl optimalizován.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Uživatelské výpisy - Filtr - DMS

DMS
Uživatelské výpisy - Filtr
Seznam kapitol

Uživatelské výpisy - Filtr

Volba podmínek pro výběr řádků pro tisk - Podmínky - FILTR

Výběr řádků, které budou tištěny. Je možné omezit nebo vybrat řádky, které budou ve výpisu tištěny. k výběru řádků slouží záložka Podmínky - FILTR.

Klikne se na tuto záložku a mohou se zapisovat podmínky.

Do řádků se mohou zapisovat podmínky filtru. Zapsané podmínky platí všechny současně ( [image]) nebo alespoň jedna z nich ( [image]).

Vyplnění podmínek

V řádku každé podmínky se vyplňují 3 pole:

  • Položka, pro kterou se bude zapisovat podmínka.

    Kliknutím myši nebo klávesou mezerník otevřete rozbalovací seznamu, kde se vybere položka, která musí splňovat určitou podmínku.

    Při výběru položky naleznete za jejím názvem informace o jejích vlastnostech (jak vyplňovat pole hodnota).

    Př. ZAPLACENO, D – pole zaplaceno obsahuje datum (úhrady)

    CASTKA, N(12,2) – pole částka obsahuje číslo s max. počtem 12 číslic před a 2 za desetinnou čárkou

    TEXT, C(30) – pole tex obsahuje řetězec o maximálním počtu 30 znaků

    REZERVACE, L – pole rezervace obsahuje logickou hodnotu ANO/NE

  • Operátor podmínka, relační znaménko.
    Význam jednotlivých relačních znamének:

    IN - položka je obsažena v seznamu, který následuje, jednotlivé hodnoty jsou odděleny čárkami, např. hledání dvou celkových částek ve fakturách

    od;do - položka je mezi hodnotami od – do, jednotlivé hodnoty jsou odděleny čárkami, např. hledání částek ve fakturách v intervalu od - do

  • Hodnota zapíše se hledaná hodnota.

V jednotlivých polích otevřete výběr kliknutím myši do pole nebo klávesou mezerník.

Tlačítka

- vymaže všechny vyplněné podmínky

- zruší jednotlivý řádek vyplněné podmínky

- vyhledávání chyb

- ukáže náhled řádků tabulky, které splňují vyplněné podmínky

- uložení nastavení výpisu

- ukáže k výběru uložená nastavení výpisů a umožňuje načíst je

Příklady

Př.1) Výběr vydaných faktur, které mají částku větší než 10 000 Kč, byly vystaveny po 1.5.2021 a zároveň mají způsob dodání Zásilkovna (Z).

Př.2) Výběr vydaných faktur, které mají částku větší nebo rovno 5 000 Kč, zároveň byly vydané před 31.10.2021, dopravu mají vyplněnou vlastní (R) a ještě nebyly vydány ze skladu (neexistuje k nim výdejka = VYDEJKA empty).

Př.3) Výběr vydaných faktur, které mají částku od 5 000 Kč do 25 000 Kč a nebo byly placeny dobírkou (způsob platby je D) tzn. ukáže všechny faktury, které mají odpovídající částky + všechny faktury které byly placeny dobírkou.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Uživatelské výpisy - formát výstupu - DMS

DMS
Uživatelské výpisy - formát výstupu
Seznam kapitol

Uživatelské výpisy - formát výstupu

Formát výstupu

Uživatel si může navolit, v jakém formátu se bude report tisknout.

Určení velikosti písma

Velikost písma - v rozsahu 4 - 24 (výška písma)
Max. šířka textu - příliš dlouhé texty může uživatel omezit zvolenou max. šířkou.
Max. šířka integer - max. šířka pro numerické položky
Max. des. míst - omezení počtu desetinných míst pro tisk

Formát papíru

Uživatel si může zvolit, na jakou velikost papíru se bude tisknout - A3, A4, A5

Tisk na výšku - užší reporty
Tisk na šířku - širší reporty
Automaticky - program podle šířky rozliší, zda se report bude tisknout na výšku nebo na šířku.

Další údaje pro generování sestavy Běžná sestava - report se tiskne jako obvykle do jednotlivých sloupců.
Detail do více řádků 1 - jedna věta se tiskne do více řádků, tisknou se tedy všechny položky.
Detail do více řádků 2 - tisknou se obdobně všechny položky do více řádků, ale i nadpisem.
Detail do více řádků 3 - tisknou se z věty pouze vyplněné položky.

Seznam výrazů pro seskupování reportu - zapíší se výrazy pro podsoučty. Např. ZN - report se bude sčítat po značkách.

Popis filtru - tiskne se pod název sestavy

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Tisk/export tabulky podle gridu ALT+ F9 - DMS

DMS
Tisk/export tabulky podle gridu ALT+ F9
Seznam kapitol

Tisk/export tabulky podle gridu ALT+ F9

V tabulkách si uživatel může často nastavit filtr nebo i pořadí sloupců v gridu. Pak by je možné vybranou tabulku rychle vytisknout nebo exportovat do excelu, aniž by musel výběr složitě tvořit. Umožní mu to funkce spuštěná klepnutím pravého tlačítka myši na tlačítko [image] (Uživatelské výpisy) nebo levého tlačítka myši na tlačítko [image] (počítadlo řádků).

Zobrazí se volba: 1. Export do Excelu podle gridu/ 2. Uživatelský výpis podle gridu.

Tlačítka [image] (Uživatelské výpisy) a [image] (počítadlo řádků) naleznete na mnoha místech našich programů:

Export do Excelu podle gridu

Tabulka podle nastavených filtrů se exportuje do xlsx souboru a otevře ho. Tento způsob vytvoření souboru funguje i tam, kde není excel k dispozici.

Soubor obsahuje uzamknutý řádek záhlaví s popisem sloupců.

Uživatelský výpis podle gridu

Tuto funkci lze vyvolat také klávesovou zkratkou ALT + F9 nebo horní lištové menu Tabulka -> Tisk/export tabulky podle gridu.

Výběr můžete bez jakýchkoli dalších úprav ihned vytisknout [image], převést do pdf [image] nebo poslat e-mailem [image] viz kapitola Volba výstupního zařízení.

Uživatelské výpisy Vám dávají mnoho dalších možností úprav tisku, například tisknout pouze sloupce, které obsahují nějaký záznam (tlačítko [image]).

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 12.06.2023


Uživatelské výpisy formát výstupu - DMS

DMS
Uživatelské výpisy formát výstupu
Seznam kapitol

Uživatelské výpisy formát výstupu

Formát výstupu

Uživatel si může navolit, v jakém formátu se bude report tisknout.

Určení velikosti písma

Velikost písma - v rozsahu 4 - 24 (výška písma)
Max. šířka textu - příliš dlouhé texty může uživatel omezit zvolenou max. šířkou.
Max. šířka integer - max. šířka pro numerické položky
Max. des. míst - omezení počtu desetinných míst pro tisk

Formát papíru

Uživatel si může zvolit, na jakou velikost papíru se bude tisknout - A3, A4, A5

Tisk na výšku - užší reporty
Tisk na šířku - širší reporty
Automaticky - program podle šířky rozliší, zda se report bude tisknout na výšku nebo na šířku.

Další údaje pro generování sestavy Běžná sestava - report se tiskne jako obvykle do jednotlivých sloupců.
Detail do více řádků 1 - jedna věta se tiskne do více řádků, tisknou se tedy všechny položky.
Detail do více řádků 2 - tisknou se obdobně všechny položky do více řádků, ale i nadpisem.
Detail do více řádků 3 - tisknou se z věty pouze vyplněné položky.

Seznam výrazů pro seskupování reportu - zapíší se výrazy pro podsoučty. Např. ZN - report se bude sčítat po značkách.

Popis filtru - tiskne se pod název sestavy

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 19.11.2020


Nápověda - F1 - DMS

DMS
Nápověda - F1
Seznam kapitol

Nápověda - F1

Při vyplňování položek, které jsou podporované číselníkem se pro zobrazení číselníku používá klávesa F1 .

Zobrazí se číselník, ve kterém se vybere požadovaná hodnota.

Tlačítko [image] potvrzení.

Tlačítko [image] provede ukončení bez výběru.

U některých tisků, kde je možné zadat více možností. např. Organizací, Středisek, zakázek, účtů se zobrazí seznam, ze kterého je umožněn Výběr. Jednotlivé položky se potom zapisují oddělené čárkami.

Tlačítka pro výběr řádků Viz. kapitola Hromadný výběr řádků.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 19.11.2020


Nápověda - DMS

DMS
Nápověda
Seznam kapitol

Nápověda

  • Nápověda - zobrazí se nápověda, elektronický manuál který je součástí distribuce programu.

  • Otevři www.comsys-sw.cz - zobrazí se internetové stránky firmy Com-Sys.

  • O aplikaci - zobrazí se informace o programu.

Jsou zobrazeny kontakty na firmu Comsys, sériové číslo, datum poslední instalované verze programu...

Datum

Datum poslední instalované verze programu je důležité pro případné řešení problémů s programem.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023


Menu Služby - DMS

DMS
Menu Služby
Seznam kapitol

Menu Služby

V menu lištovém Služby jsou nabídnuty nejpoužívanější činnosti z volby Služby – servis.

Toto menu lze proto spustit i když je na obrazovce spuštěná některá agenda. Je tak umožněno podívat se např. do nastavení parametrů, aniž by bylo nutné ukončovat spuštěnou agendu.

  • Základní parametry firmy

  • Nastavení parametrů

  • Práva přístupu

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023


Posuvníky - DMS

DMS
Posuvníky
Seznam kapitol

Posuvníky

Posuvníky jsou umístěny po obvodu tabulek např. Seznam vydaných nebo přijatých faktur, peněžní deník. Používají se také při tisku reportů na obrazovku. Slouží k listování tj. prohlížení v případě, že se tabulka, seznam report nevejde na obrazovku. Ovládají se pomocí myši.

Vertikální posuvníky jsou umístěny vpravo.

Listování v souboru – vertikálně

Značka pro listování po řádcích nahoru

Značka pro listování po řádcích dolů

Kurzor myši se nastaví na příslušnou značku (v pravém horním rohu nebo v levém dolním rohu) a stisknutím tlačítka myši zajišťuje posouvání řádků nahoru nebo dolů.

Horizontální posuvníky jsou umístěny pod seznamem, tabulkou nebo reportem.

Listování v souboru – horizontálně

Kurzor myši se nastaví na příslušnou značku a stisknutím tlačítka myši se zajišťuje posouvání textu doprava nebo doleva

Značka pro listování ve vodorovném směru doleva

Značka pro listování ve vodorovném směru doprava

Mezi značkami pro listování je značka (obdélníček) [image], která ukazuje pozici aktuálního záznamu v rámci celého souboru. Když se nastavíme kurzorem myši na tuto značku, stiskneme levé tlačítko myši a se stisknutým tlačítkem přemisťujeme kurzor požadovaným směrem po straně rámečku. Tím způsobem se můžeme také přesunout do požadovaného místa v souboru.

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 20.03.2017


Tlačítka v programu - DMS

DMS
Tlačítka v programu
Seznam kapitol

Tlačítka v programu

Tlačítka jsou prvky, které se používají pro spuštění nějaké volby, ukončení ap..

Tlačítko vybereme pomocí směrových kláves, klávesou TAB nebo myší. Výběr potvrdíme klávesou Enter nebo Mezerník nebo kliknutím levého tlačítka myši.

Tlačítko pro potvrzení např. výběru.

Tlačítko pro ukončení bez výběru.

Tlačítko pro ukončení programu.

Tlačítko Zrušené má dvě pozice:

- jsou zobrazeny řádky označené jako zrušené.

- řádky označené jako zrušené nejsou zobrazeny.

- Podrobný filtr

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 02.01.2020


Seznam - DMS

DMS
Seznam
Seznam kapitol

Seznam

Možnosti volby jsou uspořádané do řádků. Můžeme vybírat jeden nebo více řádků. Po seznamu se pohybujeme pomocí směrových kláves. Pomocí klávesy Enter nebo myší můžeme vybrat položky pro výběr. Vybraný řádek je potom kontrastně označen.

Vpravo je umístěn svislý posuvník pro pohyb myší.

Např. Seznam práv přístupu:

Označení řádku - levé tlačítko myši nebo klávesa Enter.

Označení více řádků – klávesa Ctrl+levé tlačítko myši.

Označení více řádků po sobě – klávesa Shift+levé tlačítko myši nebo Shift+Z.

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 26.06.2019


Textová pole - DMS

DMS
Textová pole
Seznam kapitol

Textová pole

Jsou to položky, do kterých se vyplňuje nějaký text, často také datum. Pohyb po polích se provádí směrovými klávesami, klávesou TAB nebo myší. Při vyplňování položky, která je podporována číselníkem, se klávesou F1 nebo pravým tlačítkem myši vyvolá zobrazení číselníku (nápovědy) ve formě menu. Výběr z číselníku se provede pomocí směrových kláves a volba se potvrdí klávesou Enter nebo zruší klávesou Esc nebo tlačítkem Storno.

Při vyplňování data stačí vyplnit pouze den a měsíc. Rok se po stisku klávesy Enter nebo levého tlačítka myši doplní automaticky.

Např. Filtry pro zadávání podmínek tisků.......

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 11.03.2020


Rozbalovací seznam - DMS

DMS
Rozbalovací seznam
Seznam kapitol

Rozbalovací seznam

Např. volba tiskárny.

Pokud u tohoto ovládacího prvku klikneme levým tlačítkem myši na šipku nebo klávesou Mezerník, rozbalí se seznam.

Např. volba tiskárny. Volbu vybereme směrovými klávesami nebo myší. Potvrdíme klávesou Enter nebo kliknutím levého tlačítka myši.

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 20.03.2017


Tabulka - DMS

DMS
Tabulka
Seznam kapitol

Tabulka

Ovládací prvek tabulka, která se používá k zobrazování údajů ve sloupcích.

Je to tabulka, kde jsou data uspořádána do sloupců.

V horní části prvku Mřížka jsou nadpisy jednotlivých sloupců. Kliknutím na konkrétní nadpis se tento sloupec setřídí vzestupně . Dvojklikem se setřídí sestupně . Toto lze využít pouze u sloupců, u kterých je nadpis podtržený a tučným písmem. V těchto sloupcích se používá i inkrementální vyhledávání , které slouží k rychlému vyhledání dokladu nebo karty atd. Kurzor musí být ve sloupci, ve kterém potřebujeme rychle vyhledávat, potom stačí postupně na klávesnici psát např. Jméno firmy a program podle zapsaných písmen vyhledává.

V pravé a v dolní části je posuvník, který se používá pro vertikální a horizontální listování v souboru. Viz kap. Posuvníky.

Přesouvání sloupců.

Umístíme kurzor myši na záhlaví s názvem sloupce, který chceme přesouvat. Stiskneme levé tlačítko myši. Přesunujeme "uchopený" sloupec (se stisknutým tlačítkem myši) až na požadované místo vpravo nebo vlevo. Uvolníme tlačítko myši.

Změna šířky sloupce

Umístíme kurzor v záhlaví sloupce na hranu, která je na pravém okraji upravovaného sloupce. Posunováním "uchopené čáry" (se stisknutým tlačítkem myši) sloupec zvětšujeme nebo zmenšujeme. Uvolníme tlačítko myši.

Automatické nastavení šířky sloupce podle délky položky

Když se 2x klikne na čáru, která je na pravý okraj upravovaného sloupce, šířka sloupce se upraví podle nejdelšího textu, tj. sloupec se rozšíří nebo zúží. Pokud se 2x klikne na malý obdélník vlevo nahoře, upraví se se takto, tj. rozšíří nebo zúží všechny právě zobrazené sloupce.

Uživatel má možnost si sám zvolit a uspořádat sloupce v tabulce. Tzn. lze si zvolit, které sloupce a v jakém pořadí budou v kterékoliv tabulce zobrazeny.

Používá se k tomu volba Zobrazení tabulky. Tato volba je umístěna v liště v menu Tabulka.

Související témata

Ovládací prvky | Posuvníky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 11.03.2020


Zobrazení tabulky - DMS

DMS
Zobrazení tabulky
Seznam kapitol

Zobrazení tabulky

Ovládací prvek mřížka je tabulka, která slouží k zobrazování dat. Data jsou uspořádána do sloupců. Uživatel má možnost si sám zvolit a uspořádat sloupce v tabulce. Tzn. lze si zvolit, které sloupce a v jakém pořadí budou v kterékoliv tabulce typu mřížka zobrazeny.

Používá se k tomu volba Zobrazení tabulky z horního lištového menu Tabulka.

Tlačítko [image] také přepne do Nastavení sloupců. toto tlačítko se používá zejména v rozpisech dokladů jednotlivých agend.

Nastavení sloupců

Pomocí směrových tlačítek se vyberou pouze sloupce, které se nebudou zobrazovat. Všechny sloupce z tabulky jsou seřazeny vpravo v okně Zobrazené sloupce. Z nich vybereme sloupce, které nepotřebujeme zobrazovat a přesuneme je vlevo do okna Nezobrazené sloupce. Přesouvání sloupců lze provádět i opačně. Z nezobrazených do zobrazených.

- vyřadit ze zobrazených sloupců sloupec, na kterém je kurzor

- vyřadit všechny zobrazené sloupce

- zařadit do zobrazených sloupců sloupec, na kterém je kurzor

- vyřadit všechny nezobrazené sloupce

Přesunutí sloupců

Značka před zobrazeným sloupcem nám umožní tento sloupec přesunout na požadované místo v tabulce.

Umístíme kurzor myši na tuto značku před sloupec, který chceme přesouvat. Přesunujeme "uchopený" sloupec (se stisknutým tlačítkem myši) až na požadované místo nahoru nebo dolů. Uvolníme tlačítko myši.

  • Zobrazit - zobrazí se nové uspořádání sloupců v tabulce.
  • Ulož nastavení - nastavení sloupců lze uložit, aby se vždy zobrazovaly tak, jak jsme si zvolili.
  • Vrátit implicitní - obnoví se původní nastavení sloupců. Stejná volba jako Návrat k originálu.
  • Konec - konec práce nastavení sloupců.

Úprava šířky sloupců

Je možné upravit šířku sloupců tak, aby se přizpůsobily nejdelšímu textu ve sloupci.

Dvojklikem myši na čtvereček vlevo nahoře se provede úprava šířky sloupce podle jeho obsahu.

Tabulka se přizpůsobí obsahu jednotlivých sloupců.

Velikost okna

V menu tabulka Uložení velikosti okna. Pomocí myši je možné zvětšit okno na obrazovce.

V rozpisech dokladů se k tomu používá tlačítko [image].

Tlačítka

- zobrazí se nové uspořádání sloupců v tabulce.

- nastavení sloupců lze uložit, aby se vždy zobrazovaly tak, jak jsme si zvolili. Stejná volba je i v menu Tabulka.

- obnoví se původní nastavení sloupců.

Stejná volba jako Návrat k originálu z menu Tabulka.

- konec práce nastavení sloupců.

Zákaz vybraných položek

Činnost Zákaz vybraných položek. Při pořizování dokladů, vydané faktury, přijaté faktury a další, si může uživatel nastavit, které položky na kartě dokladu bude používat. Položky, které nepotřebuje vyplňovat, může zakázat a nebude do nich vstupovat.

V menu Tabulka Nastavit zakázané položky. Nastavuje se samostatně v každé agendě. Např. Vydané faktury, Přijaté faktury.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 11.03.2020


Předvolba - DMS

DMS
Předvolba
Seznam kapitol

Předvolba

Nastavení předvolby je nezávislé na jiné, tzn. že může být zvoleno několik předvoleb. Předvolba má dvě polohy

  • Ano - okénko zaškrtnuté
  • Ne - okénko prázdné

Přepínání klávesou Enter nebo myší.

Upozornění

Pozor na náhodný výběr, pokud se po položkách pohybujeme klávesou Enter, a ne směrovými klávesami nebo klávesou Tab.

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 20.03.2017


Přepínače - DMS

DMS
Přepínače
Seznam kapitol

Přepínače

Přepínače se vyskytují vždy ve skupině. Může být nastaven ve skupině vždy jediný. Nastavení vybereme směrovými klávesami a potvrdíme klávesou Enter nebo kliknutím myši.

Používají se především při tisku, kdy volíme typy sestav.

Související témata

Ovládací prvky
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 21.08.2020


Obrázková tlačítka - DMS

DMS
Obrázková tlačítka
Seznam kapitol

Obrázková tlačítka

Ovládací prvek Obrázková tlačítka se vyskytuje ve všech agendách programu. Používají se k zakládání, opravě, editaci, rušení řádků nebo pro listování po řádcích.

Jsou vždy umístěna ve spodní části obrazovky.

Pro snadnější orientaci obsahují tlačítka malou nápovědu. Tato nápověda se zobrazí pokud se nechá kurzor myši pár okamžiků na tlačítku.

1) Tlačítka pro posun po větách

  • na začátek, na první řádek v souboru

  • na předcházející řádek

  • na následující řádek

  • na poslední řádek v souboru, na konec

2) Vyhledávání

K vyhledání věty splňující určitou podmínku. Stejná funkce jako klávesa F7 - Hledej.

3) Tisk

Pod tímto obrázkem je tiskové menu.

4) Vložení nové věty

Vložení nové prázdné věty tj. vložení nového řádku (účetní deník, číselníky) Stejná funkce jako klávesa F6. V režimu úprav toto tlačítko mění svou funkci na Uložit .

To znamená, pokud doklad opravujeme, tak toto tlačítko má funkci Konec, Uložit.

5) Editace věty

Oprava vybraného řádku . Řádek je otevřen pro editaci. Stejná funkce jako klávesa F4.

V režimu úprav toto tlačítko mění svou funkci na Zrušit změny.

6) Zrušení nebo Obnovení věty

Tímto tlačítkem se aktuální řádek označí jako zrušený, program s ním nepracuje.Pokud je řádek již označená jako zrušená toto tlačítko ji znovu obnoví. Stejná funkce jako klávesa F8. Vlevo před zrušeným řádkem se objeví znak n.

Lze nastavit, jestli se budou zrušené položky zobrazovat nebo ne. Používá se pro to tlačítko "Zrušené", které má dvě pozice.

- jsou zobrazeny řádky označené jako zrušené.

- řádky označené jako zrušené nejsou zobrazeny.

Vymazání vět označených jako zrušené se provede

  • z agendy Služby – Servis přes tlačítko

Je třeba vybrat, ve které tabulce (souboru) se bude provádět mazání vět.

  • přímo z menu tabulka volbou : Mazat zrušené věty.

7) Uživatelské výpisy

Pro tisk vybraných informací z libovolné databáze slouží universální program Uživatelské výpisy.

8) Řazení

Změna pořadí, umožní změnit pořadí vět v souboru (např. účetní deník, účetní osnova). V tabulce se zvolí položka, podle které bude databáze uspořádána. Stejná funkce jako klávesa F3 Pořadí.

9) Konec

Tlačítko Konec uloží změny, které uživatel zapsal (vkládání, opravy) a ukončí činnost nebo i agendu. Stejná funkce jako klávesa F2.

Tlačítko [image] nebo [image] - potvrzení.

Tlačítko [image] provede ukončení bez výběru.

Tlačítka pro výběr kapitola Hromadný výběr řádků.

Související témata

Ovládací prvky | F7 - Hledej | F9 - Uživatelské výpisy
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 03.01.2022


Klávesy pro ovládání - DMS

DMS
Klávesy pro ovládání
Seznam kapitol
Klávesy pro ovládání

Tyto rychlé klávesy jsou využity v celém programu. Používají se k zakládání, opravě, editaci, rušení řádků nebo pro listování po řádcích. Mají stejnou funkci jako Obrázková tlačítka.

Klávesy jsou nabídnuty v Menu tabulka.

Pohyb po jednotlivých větách databáze:

  • Ctrl Home - na začátek, na první větu v souboru -

  • PageUp - na předcházející větu -

  • Ctrl PageDown - na následující větu -

  • Ctrl End - na poslední větu v souboru, na konec -

F1

Klávesa pro nápovědu z číselníku. Používá se na položkách, ve kterých se vyplňuje hodnota z číselníku. Zobrazí se číselník pro výběr hodnoty.

F6

Vložení nové prázdné věty tj. vložení nového řádku, nového dokladu.
Obrázkové tlačítko

F4

Oprava vybraného řádku. Po stisknutí této klávesy je řádek je připraven pro editaci.
Obrázkové tlačítko

F2

Ulož změny. Klávesa F2 uloží změny, které uživatel zapsal (vkládání, opravy) a ukončí činnost.
Obrázkové tlačítko

F5

Kopíruj větu. Klávesa F5 provede kopii aktuálního dokladu nebo řádku.

F8

Zruš, označení aktuálního řádku nebo dokladu, na kterém je nastaven kurzor jako zrušeného. Program s ním nepracuje, ale je možnost jej opět znovu obnovit. Před zrušeným řádkem je zobrazen znak n a při opětovném použití této klávesy je řádek obnoven.
Do formuláře se zapíše označení Zrušena!.
Obrázkové tlačítko

Lze nastavit, jestli se budou zrušené položky zobrazovat nebo ne. Používá se pro to tlačítko "Zrušené", které má dvě pozice.

- jsou zobrazeny řádky označené jako zrušené.

- řádky označené jako zrušené nejsou zobrazeny.

Fyzické zrušení řádků, které jsou označeny jako zrušené se provede volbou Mazat zrušené věty.

Je-li věta označena jako zrušená, zůstává nadále v souboru, nepočítá se s ní, netiskne se do soupisů nebo přehledů ale je možné ji kdykoliv volbou F8 obnovit.

Před zálohováním, je vhodné zrušené věty vymazat.

ALT+M - Mazat zrušené věty

Tato činnost provede úplné vymazání zrušených vět, tj. těch, které jsou v souborech označené jako zrušené klávesou F8 nebo tlačítkem [image].

Při práci v síti je možné tuto činnost provést pouze v případě, že ze souborem nepracuje jiný uživatel

Mazání vět, které jsou označeny jako zrušené lze také provést v každé agendě pomocí stejných kláves.

Je možnost si ještě prohlédnout, kterých vět se bude mazání týkat - Ukaž zrušené.
Volba Vymazat provede vymazání vět, které byly označeny jako zrušené.

Mazat zrušené - Hromadné mazání zrušených vět.

F3

Změna pořadí, umožní změnit pořadí vět v databázi, (např. vydané, přijaté faktury). V tabulce se zvolí položka, podle které bude databáze uspořádána. F3 – Pořadí
Obrázkové tlačítko

F7

Hledej, hledání věty s určitou hodnotou položky. Tato volba zobrazí okno, kde se vyplní parametry vyhledávání. F7 - Hledej
Obrázkové tlačítko

F9 - uživatelské výpisy

Pro tisk vybraných informací z libovolné databáze slouží universální program F9 - Uživatelské výpisy výpisy.
Obrázkové tlačítko

Zapisování data

Rychlé klávesy pro zapisování data

Klávesa přepíše datum o jeden den vyšší.
Klávesa přepíše datum o jeden den nižší.

Značka ^ = klávesa CTRL

Související témata

Ovládací prvky | Přehledná tabulka tlačítek a kláves | F7 - Hledej | F9 - Uživatelské výpisy |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 18.02.2022


Přehledná tabulka tlačítek a kláves - DMS

DMS
Přehledná tabulka tlačítek a kláves
Seznam kapitol

Přehledná tabulka tlačítek a kláves

Tlačítka | Klávesy | Popis
 | Ctrl+Home | Na začátek souboru
 | Ctrl+PageUp | Na předcházející větu
 | Ctrl+PageDown | Na následující větu
 | Ctrl+End | Na konec souboru
 | F6 | Vložení nové věty
 | F4 | Editace věty
 | Esc | Storno úprav
 | Esc | Konec agendy
 | F2 | Konec editace s uložením
 | F8 | Zrušení/Obnovení věty
 | F7 | Hledej hodnotu
 | F3 | Změna pořadí
 | F9 | Uživatelské výpisy
 | Ctrl+T | Tiskové menu

Související témata

Klávesy pro ovládání |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 03.01.2022


Záložky - DMS

DMS
Záložky
Seznam kapitol

Záložky

V některých agendách se pracuje s několika listy, které se jmenují Záložky.

Jejich název je vždy v horní části obrazovky.

Např. u vydaných faktur jsou záložky: Seznam, Karta, Rozpis

Přepínání mezi záložkami:

  • myší - kliknutím levého tlačítka myši
  • klávesami - ALT+ podtržené písmeno z názvu. Např. ALT+S, ALT+K, ALT+R

Dole na záložce jsou vždy Obrázková tlačítka, která se používají pro ovládání pomocí myši.

V horním menu je Menu tabulka, které se používá pro ovládání pomocí klávesnice.

Související témata

Menu tabulka |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 03.01.2022


Podrobný filtr - DMS

DMS
Podrobný filtr
Seznam kapitol

Podrobný filtr

Rychlý filtr

V některých agendách se také pro podrobné vyhledávání používá filtr. Tento filtr může vyhledávat ve zvolených položkách (sloupcích) tabulky.

Prohledávané sloupce

Standardně vyhledává filtr pouze v textových položkách. Ale uživatel má možnost změnit výběr sloupců, které filtr prohledává.

Kliknutím myši na ikonku lupy - [image] - se zobrazí tabulka položek použitých v tabulce. Uživatel vybere, ve kterých položkách bude filtr vyhledávat. Výběr zůstane nastavený nastálo, nemusí se opravovat.

Vyhledávání

Uživatel uživatel zapisuje hledaný výraz do filtru -> program nabízí pouze věty, které tento výraz obsahují.

Položky, v kterých se filtruje se vždy zobrazí, když se kurzorem ukáže na ikonku lupy.

Příklad: Hledá se faktura, která má místo určení Nový Smíchov.

  • 1.Do seznamu položek, ve kterých se vyhledává se přidá Místo určení.
  • 2.Do filtru se zapíše hledaný výraz Nový
  • 3.Filtr vyhledá všechny faktury, kde se vyskytne výraz Nový

- podle zadaného filtru jsou vyhledány věty

- zvolenému filtru neodpovídá žádná věta

Klepnutím na křížek - [image] - vymaže filtr.

Datum se zadává ve tvaru – dd.mm.rrrr. Den-Měsíc-Rok.

Velké množství položek v tabulce

Pokud filtr vyhledává v tabulce s velkým množstvím položek, může být vyhledávání poměrně pomalé.

Zrychlení se dá dosáhnout omezením počtu vyhledávaných sloupců (viz výše) nebo nastavením začátku vyhledávání, až po zmáčknutí klávesy Enter.

Parametr "Rychlé hledání průběžně při počtu vět v tabulce do ... quickfilter" (QUICKF_VET_DO) určuje, od jakého počtu vět se v tabulce vyhledává v rychlém filtru až o zmáčknutí klávesy Enter. Implicitní nastavení je 10 000 vět. Pokud chcete vyhledávání zrychlit nastavte parametr na nižší hodnotu.

Horní lištové menu Služby -> Nastavení parametrů -> parametr QUICKF_VET_DO

Při zapisování a vyhledávání je v případě vyhledávání v rychlém filtru až o zmáčknutí klávesy Enter podbarvení pole filtru i při zapisování stále žluté [image].

Filtr v číselnících

V číselnících se používá filtr pro výběr vět.

Tlačítka

- nastaví se filtr podle zadaných podmínek. vyberou se pouze věty podle zadaných podmínek.

- filtr se vypne.

- zruší se zadání podmínek a je možné zadat nové.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 08.06.2022


Hromadný výběr řádků - DMS

DMS
Hromadný výběr řádků
Seznam kapitol

Hromadný výběr řádků

V některých agendách se používá hromadný výběr řádků.

V tabulce je zobrazen seznam položek a uživatel si může hromadně vybrat některé pro další použití.

Tlačítka pro výběr položek

- výběr jednoho řádku. 2 pozice: výběr nebo zrušení výběru jednoho řádku.

- vybraný řádek

- nevybraný řádek

- tlačítko označí všechny řádky jako vybrané

- tlačítko označí všechny řádky jako nevybrané

- provede inverzi tj. prohodí vybrané a nevybrané řádky

Tlačítko [image] - potvrzení.

Tlačítko [image] provede ukončení bez výběru.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 23.03.2017


Zavedení firmy - DMS

DMS
Zavedení firmy
Seznam kapitol
Zavedení firmy

Postup založení evidence pro další firmu:

  • Založení nového zákazníka. Zákazník je v našem programu firma, které je vedena docházka.
  • Výběr zákazníka jako aktuálního
  • Vyplnění číselníků
  • Nastavení parametrů
  • Zpracování dat

Související témata

Založení nového zákazníka | Výběr zákazníka | Pracovní období | Vyplnění číselníků | Nastavení parametrů |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


Založení nového zákazníka - DMS

DMS
Založení nového zákazníka
Seznam kapitol

Založení nového zákazníka

Program umožňuje vést účetnictví libovolnému počtu navzájem nezávislých firem. Jednotlivé subjekty, kterým je účetnictví vedeno, jsou nazývány zákazníci programu.

To také umožňuje, aby byl v programu veden současně vzorový příklad jako zákazník PŘÍKLAD, v jehož účetnictví si můžeme vyzkoušet, jak program funguje.

Vložení nového zákazníka tj. firmy, které bude vedeno v programu Docházka se provede pomocí menu Číselníky / Zákazníci programu:

Program se přepne do číselníku zákazníci a v dolní části jsou zobrazena obrázková tlačítka pro ovládání.

Pro založení nového zákazníka se použije tlačítko - Vložit novou větu [image]. Lze použít i klávesu F6.

Pro vyplnění označení a názvu firmy se v dolní části obrazovky otevře prázdný editační řádek.

  • Označení - zkratka pro jméno firmy na 8 znaků. Označení pro každou firmu jiné. Ve jménu označení se nesmějí používat mezery, pomlčky, tečky. Je možné použít znak podtržítko: Např. COM_SYS. Používají se velká písmena. Označení se použije pro jméno složky, do které se ukládají data firmy.

  • Název - název firmy

Ukončit vložení nového zákazníka tlačítko

Potom je potřeba nového zákazníka vybrat jako aktuálního. Viz. Výběr zákazníka.

Související témata

Výběr zákazníka | Pracovní období | Vyplnění číselníků | Nastavení parametrů |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


Výběr zákazníka - DMS

DMS
Výběr zákazníka
Seznam kapitol

Výběr zákazníka

Výběr zákazníka (firmy), s jehož daty se bude pracovat se provede přes tlačítko Zákazník z hlavní obrazovky.

Tato činnost zobrazí seznam všech dosud nadefinovaných zákazníků. Vybereme hledaného zákazníka a potvrdíme tlačítkem OK. Můžeme použít inkrementální vyhledávání. postupně zapisujeme na klávesnici organizaci a je prováděno hledání. Pro myš jsou posuvníky vpravo.

Na hlavní obrazovce je potom zobrazeno jméno zákazníka (firmy), která je aktuální, pro kterou se zpracovávají data.

Neaktuální zákazník (firma)

Tento výběr neaktuálního zákazníka je platný pouze pro uživatele, který si jej takto nastavil.

Uživatel má možnost navolit si, které firmy se budou při výběru zobrazovat. Toto je výhodné pro účetní firmy, které vedou účetnictví většímu množství zákazníků a každý uživatel zpracovává data jiné firmy.

Na tlačítko [Zákazník] klikneme pravým tlačítkem myši. Zobrazí se seznam všech firem, které jsou v programu založené a uživatel si označí, které se budou právě jemu nabízet v seznamu.

- firmy, které se budou nabízet v seznamu zákazníků

- firmy, které se nebudou nabízet v seznamu zákazníků

Tento výběr jde kdykoliv změnit.

Po založení a výběru nového zákazníka je vhodné použít činnost z menu Servis / Základní parametry firmy pro vyplnění základních parametrů.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 31.05.2023


Vyplnění číselníků - DMS

DMS
Vyplnění číselníků
Seznam kapitol

Vyplnění číselníků

Program vyžaduje pro správnou funkci vyplnit některé číselníky.

V číselnících se nastavují hodnoty, kterých mohou nabývat konkrétní pole při zpracování dokumentů př. typy nebo stavy dokumentů. Je možné v nich také nastavovat barvy, jakými bude pole s danou hodnotou v seznamu zabarveno.

Podrobně viz kapitola Číselníky

Související témata

Seznam středisek | Číselníky | Kalendář svátků | Servis |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 02.06.2023


Pořízení - DMS

DMS
Pořízení
Seznam kapitol

Pořízení

Slouží ke vkládání nových dokumentů. Má 4 základní oblasti.

1) Seznam dokumentů

2) Náhled – zobrazuje dokument označený v seznamu

3) Volba typu dokumentu

4) Základní informace o dokumentu

Založení dokumentu

Nový dokument se do seznamu založí tlačítky

Ze souboru – výběr jednotlivého souboru

Z více souborů – hromadný výběr více souborů z jedné složky

Tlačítkem [image] vyberte složku, ze které chcete dokumenty nahrát.

Soubory označené [image] budou nahrány do seznamu dokumentů (soubory označené [image] ne). Vpravo vidíte náhled označeného dokumentu. Pomoci najít konkrétní dokument může také filtr v horní části [image] ( [image] občerstvení seznamu po vyplnění nebo vymazání filtru).

Tlačítkem [image] nahrajete vybrané soubory do programu.

Naskenovat – dokumenty lze do seznamu dokumentů také naskenovat.

Prázdný – založí hlavičku nového dokumentu, kterou můžete upravovat (př. očekávám nějaký dokument). Do dokumentu pak lze přetahovat soubory př. z e-mailu podrobně viz níže.

Náhled

Dokument může obsahovat více souborů (př. fotodokumentace). V dolní části jsou pak jednotlivé soubory označeny čísly. Označené číslo zobrazí náhled příslušného souboru.

Tlačítkem [image] otevřete formulář, ve kterém můžete přidat nebo upravit soubory patřící k danému dokumentu.

Do označené oblasti s náhledem vpravo je možné přetahovat soubory př. z e-mailu (ty se pak objeví v seznamu souborů v levé části).

Výběr typu dokumentu

Při zpracování dokument je možné dokument zařadit do nějakého typu (z číselníku Typy dokumentů), podle kterého je pak možní dokumenty filtrovat nebo nastavit pro určitý typ dokumentů jednotnou cestu zpracování (př. typ faktura za dopravu půjde automaticky ke schválení vedoucímu dopravy). Vyplnit typ dokumentu není pro jeho další zpracování nutné.

Vyplnění základních informací o dokumentu

Vyplnění základních informací o dokumentu, které vím a možnost předání dokumentu ke zpracování (kontrole, schválení, zaúčtování atd.) někomu dalšímu.

Dokument vidím pouze já v této agendě až do chvíle, než mu nastavím nějaký stav! Pak zmizí z této agendy a zobrazuje se podle nastavených informací v ostatních agendách a ostatním uživatelům, podle nastavených oprávnění.

Název – libovolný název dokumentu

Code

Zákazník – zákazník programu (F1 na výběr) Organizace, Firma

Stav dokumentu – př. z zaúčtování, schválit vedoucí střediska 1 atp. (z číselníku Stavy dokumentů).

Řešitel – role (číselník Role), - osoba (číselník Uživatel) -> komu předávám dokument k dalšímu zpracování

Termín – do kdy má být dokument př. schválen, po termínu se zobrazuje v agendě „Po termínu“

Poznámka – libovolná poznámka, zobrazuje se i dalším, kdo s dokumentem pracují

- pod tímto tlačítkem naleznete například volbu úplně vymazat tento dokument

- uloží vyplněné informace k dokumentu. Pokud vyplníte stav, přesune se dokument z této agendy. Zobrazuje se pak podle nastavených informací v ostatních agendách a ostatním uživatelům, podle nastavených oprávnění.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 31.05.2023


Dokumenty - DMS

DMS
Dokumenty
Seznam kapitol

Dokumenty

Základní agenda programu, ve které se dokumenty upravují, schvalují, posílají k dalšímu zpracování atd.

V levé části je zobrazen seznam všech dokumentů, ke kterým máte oprávnění.

V horní části naleznete podrobný filtr k hledání konkrétního dokumentu. F1 dá na výběr z příslušného číselníku.

Zaškrtnutím některé z voleb [image] zobrazíte předem připravené filtry, které lze spustit také jako samostatné agendy z hlavní obrazovky.

V pravé části naleznete podrobnosti do dokumentu, kdo ho má v tu chvíli na starosti (Řeší), v jakém je stavu. Pokud je spárován s nějakým konkrétním dokladem z některého z našich programů, tak v dolní části podrobnosti o tomto dokladu. Všechna pole jsou informační, upravovat se dají pouze přes funkční tlačítka.

- otevře formulář, kde je možné měnit údaje vyplněné k daném dokumentu

- slouží k párování dokumentu s doklady z našich programů. Podle vyplněných informací nabídne vhodné kandidáty.

- zobrazí informace o historii dokladu, kdo kdy a jak ho měnil, předal k dalšímu zpracování atd.

Přepínačem [image] / [image] označíte dokument jako oblíbený ano (označení [image])/ ne.

Tlačítko [image] zobrazuje počet přiložených souborů a otevírá formulář, kde je možné soubory upravovat a přidávat další.

Do označené oblasti s náhledem vpravo je možné přetahovat soubory př. z e-mailu (ty se pak objeví v seznamu souborů v levé části).

Tlačítko [image] - zobrazí náhled přiloženého souboru. Pokud je souborů víc, přechází se mezi nimi tlačítky s čísly [image].

Tlačítko [image] / [image] umožňuje náhled „přišpendlit“. - zobrazují se náhledy souborů připojených k dokumentu, který je aktuálně označen v seznamu.

- umožňuje tisk historie zpracování dokumentu

Změnit

V levé části formuláře naleznete informace o spárovaném dokumentu.

V pravé části jsou informace o dokumentu, které lze měnit.

Poznámka – v přehledu dokumentů se zobrazuje vždy poslední poznámka, kterou někdo uložil. Všechny starší poznámky naleznete v historii dokumentu (tlačítko Log).

- umožňuje změnu typu dokumentu, ale pouze v případě, že není spárován s dokladem.

Tlačítko [image] umožňuje odpárovat doklad od daného dokumentu.

Spárování dokumentu s jiným dokladem se provede z přehledu dokumentů tlačítkem Spáruj z hlavní obrazovky přehledu dokumentů.

Nastavení oprávnění: Služby -> Práva přístupu

  • Párování dokumentů – právo 1 pro agendu „dmsprehled“

  • Odpárování dokumentů – právo W pro agendu „odparovani“

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 06.06.2023


Náhledy do agedny s dokumenty - DMS

DMS
Náhledy do agedny s dokumenty
Seznam kapitol

Náhledy do agedny s dokumenty

Tyto agendy otevírají tabulku s doklady s přednastavenými filtry.

Číslo za názvem agendy zobrazuje počet dokumentů, které vyhovují danému filtru.

Řeším já – přehled dokumentů, ve kterých jsem byl já označen jako řešitel (jmenovitě nebo jako role př. účetní, skladník atp.)

Oblíbené - přehled dokumentů, které mám já označené, jako oblíbené ( [image]), chci je sledovat.

Poslední - přehled dokumentů, které jsem upravoval za posledních 30 dní.

Po termínu - přehled dokumentů, které mají nastavený termín, do kdy mají být vyřízené a je po tomto datu. Číslo ukazuje počet dokumentů po termínu, které mám řešit já.

-> tzn. existuje 16 dokumentů, ve kterých jsem já označen, jako řešitel a tímto tlačítkem otevřu seznam s danými dokumenty.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023


Číselníky - DMS

DMS
Číselníky
Seznam kapitol

Číselníky

V číselnících se nastavují hodnoty, kterých mohou nabývat konkrétní pole při zpracování dokumentů př. typy nebo stavy dokumentů. Je možné v nich také nastavovat barvy, jakými bude pole s danou hodnotou v seznamu zabarveno.

Pro nastavování číselníků musí mít uživatel nastavená práva přístupu.

Hodnoty v číselnících se často nastavují zaškrtáváním ve formuláři výběr.

- ano

- ne

Role uživatelů – jednu roli může mít nastaveno více uživatelů (př. účetní, vedoucí autodopravy atp.). Dokumenty je možné předat ke zpracování všem uživatelům s nastavenou danou rolí.

Stavy dokumentů – dokumenty při zpracování prochází různými stavy. Je možné nastavit, jakých stavů může dokument určitého typu nabývat.

Typy dokumentů – typy dokumentů, které nastavují při zpracování dokumentů. Dokumenty je možné podle typu filtrovat nebo nastavit pro určitý typ dokumentů jednotnou cestu zpracování (př. typ faktura za dopravu půjde automaticky ke schválení vedoucímu dopravy).

Uživatel – uživatelé programu, je možné nastavovat práva přístupu uživatele a role, jaké má konkrétní uživatel.

- ano, uživateli se zobrazí dokumenty určené ke zpracování příslušnou rolí

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023


Oprávnění zobrazení dokumentů - DMS

DMS
Oprávnění zobrazení dokumentů
Seznam kapitol

Oprávnění zobrazení dokumentů

Oprávnění pro zobrazení konkrétních dokumentů se nastavují pro jednotlivé role.

Př. „účtárna“ může vidět všechny dokumenty, ale „vedoucí autodopravy“ pouze faktury přijaté za dopravu (typ dokumentu).

Nastavení oprávnění: na hlavní obrazovce zvolte Servis -> C. Nastavení: Role – Typ dokumentu a označte [image] typy dokumentů, které může osoba s nastavenou danou rolí zobrazit.

Dokumenty, na které nemá oprávnění se dané roli nezobrazují při prohlížení dokumentů a nemůže si je ani exportovat funkcí „Export vybraných dokumentů“.

Nastavení oprávnění

  • Služby / servis C. Nastavení: Role - Typ dokumentu

  • Číselník dmRole - tlačítko Práva role - typ d.

  • Číselník dmTyp - tlačítko Práva role - typ d.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 30.05.2023


Export vybraných dokumentů do souboru - DMS

DMS
Export vybraných dokumentů do souboru
Seznam kapitol

Export vybraných dokumentů do souboru

Program umožňuje vybrat dokumenty, které budou exportovány do jedné složky, export obsahuje také seznam.txt soubor, který obsahuje seznamem exportovaných dokumentů. Tato funkce je vhodná například ke generování příloh pro finanční úřad atp.

Tlačítko [image] v agendě dokumenty (v pravém dolním rohu) -> volba Exportovat vybrané dokumenty do složky.

Otevře se formulář pro výběr dokumentů. Zobrazené dokumenty odpovídají omezením nastaveným ve filtrech v hlavním formuláři.

Typ dokladu

Vložen od data – dokumenty vložené od nastaveného data

Do data – dokumenty vložené do nastaveného data

Z roku – dokumenty z konkrétního roku

Atd.

Výběr dokumentů k exportu obsahuje 1 řádek za každou přílohu (př. každá fotka má svůj samostatný záznam). Pokud dokument nemá přílohu, pak není v seznamu k výběru.

- takto označený soubor bude zařazen do exportu

Volba [image] otevře formulář pro volbu složky, do které budou dokumenty exportovány. V tomto formuláři lze také novou složku založit.

Vyberte složku -> [image] provede se export a zobrazí se protokol se soupisem exportovaných dokumentů.

• Nastavení oprávnění – Servis -> Práva přístupu -> agenda „dmsprehled“, Právo E

• Uživatel může exportovat do souboru pouze dokumenty, které má právo zobrazit.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 31.05.2023


Servis - DMS

DMS
Servis
Seznam kapitol
Servis

Na hlavní obrazovce zvolte agendu Servis -> otevře se menu:

Základní nastavení

  • Práva přístupu - nastavení práv přístupu uživatelů
  • Základní parametry firmy - Nastavení základních parametrů firmy: adresa, IČO, DIČ, telefon, e-mail.
  • Nastavení parametrů - Pro jednotlivé zákazníky je možné nastavit některé parametry a tak ovlivnit chování programu pro každého zákazníka, především pro některé automatické operace nastavit implicitní hodnoty.

Importy dokladů z jiných programů

  • Import dokladů CM1 - přijaté a vydané fatury - import dat z programu Company Manager (MANW)
  • Import dokladů Frutis - kamiony nákupy - import dat z programu Frutis

Servisní činnosti

  • Kontrola struktury databáze po instalaci nové verze
  • Doplnit foto_agenda pro spárováné doklady

Nastavení k číselníkům:

  • Nastavení: Typ dokumentu - Stav
  • Nastavení: Uživatel - Role
  • Nastavení: Role - Typ dokumentu - Stav
  • Nastavení: Uživatel - Typ dokumentu - Stav
  • Nastavení: Role - Typ dokumentu

Funkce spouští tabulky, které umožňují nastavit oprávnění pro zobrazení určitých typů dokumentů, párování dokumentů s doklady, nastavení konkrétních stavů zpracování atp. pro určité skupiny uživatelů (role).

Přiřazení role uživateli, možné typy dokumentů, možné stavy zpracování dokumentů najdete v Číselnících, z nich se pak ve funkcích Nastavení zobrazují možnosti na výběr/zaškrtnutí.

Př.

Kombinace označené [image] jsou povolené, [image] ne (uživatel daný typ dokumentů nevidí, nemůže tisknout, nemůže nastavit daný stav dokumentu atd.).

Související témata

Číselníky | Nastavení parametrů | Práva přístupu |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


Nastavení parametrů - DMS

DMS
Nastavení parametrů
Seznam kapitol

Nastavení parametrů

Na horní liště zvolte Služby-> Základní parametry firmy/ Nastavení parametrů.

Nastavení parametrů lze otevřít také klávesovou zkratku ALT+F1.

Základní parametry firmy

Nastavení základních parametrů firmy: adresa, IČO, DIČ, telefon, e-mail.

Nastavení parametrů

Pro jednotlivé zákazníky je možné nastavit některé parametry a tak ovlivnit chování programu pro každého zákazníka, především pro některé automatické operace nastavit implicitní hodnoty.

Položky číselníku parametrů:

  • Název - název parametru
  • Klíč - název položky v databázi
  • Typ - typ položky
  • Sada
  • Implicitní - jaká je přednastavená hodnota parametru v programu
  • Aktuální hodnota - nastavená hodnota parametru, tj. kterou má uživatel možnost změnit

Pro jednotlivé zákazníky je možné nastavit některé parametry a tak ovlivnit chování programu pro každého zákazníka, především pro některé automatické operace nastavit implicitní hodnoty.

Související témata

Postup při nastavování parametrů | Parametry programu
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


Práva přístupu - DMS

DMS
Práva přístupu
Seznam kapitol

Práva přístupu

Jestliže nejsou nastavena práva přístupu, otvírá se program rovnou do hlavní obrazovky.

Jsou-li nastavena práva přístupu pro jednotlivé pracovníky, je umožněn vstup jen těm, kteří mají nějaká práva nastavená.

Související kapitola Oprávnění zobrazení dokumentů - v rámci agend, do kterých má uživatel právo přístupu, je možné nastavit oprávnění zobrazit jen některé typy dokumentů atp.

V menu Práva přístupu má možnost správce programu nastavit práva přístupu do jednotlivých agend pro pracovníky, kteří s programem pracují (zákaz, čtení, vkládání dat). Používá se tam, kde s programem pracuje více osob nebo se program provozuje v síti.

Agenda práva přístupu má 4 záložky

  • Práva - vlastní nastavení práv přístupu

  • Uživatelé - číselník oprávněných uživatelů

  • Agendy - číselník agend, ve kterých přichází v úvahu nastavení práv přístupu

  • Žurnál - číselník uživatelů, kteří s programem právě pracují

- Podrobný filtr

Filtr na výběr aktuálních i neaktuálních uživatelů. Zobrazuje se podle vyplněné položky - Blokovat od.

Práva by měl nastavovat správce programu.

Nezapomeňte nastavit právo pro samotného správce programu.

Postup

Nejprve se otevře záložka uživatelů a správce programu zapíše do číselníku uživatelů seznam jednotlivých oprávněných uživatelů programu (Kód uživatele na 5 znaků a jméno uživatele).

Záložka Uživatelé

Tlačítko [image] nebo klávesa F6 založí nový řádek pro vyplnění uživatele.

Vyplní se potřebné položky pro uživatele.

Kód uživatele - přihlašovací kód na 5 znaků. Použije se pro přihlašování do programu.

Jméno a příjmení

Přihlašovací jméno - 30 znaků. Má stejný význam jako Kód uživatele. Může se také použít pro přihlašování do programu.

Platnost hesla - je možné omezit platnost hesla, které si zadává uživatel. Pokud není vyplněné, platnost hesla je bez omezení.

Podle uživatele - v číselníku uživatelů se může zadat obecný uživatel jako například účetní, fakturantka, skladník ap. nastaví se mu práva a potom uživateli, který vykonává stejnou činnost se zadá Podle uživatele ,účetní, a program automaticky nastaví stejná práva.

ID schéma - pouze pro agendu Požadavkové listy.

Skupiny uživatelů - pro posílání zpráv v programech Výroba, Logis, ILS.

Mimo aktuální rok odebrat práva - zapíše se znak činnosti, na kterou uživatel mimo aktuálního roku nemá právo. Např. A - vkládání, W - zápis (editace). Pokud se vyberou všechny práva, uživatel nebude mít přístup do dat minulých let.

E-mail, Telefon, Mobil - informace o uživateli E-mail - tato e-mailová adresa se použije jako odesílací adresa pro odesílání dokumentů e-mailem. Také se tiskne do faktury, pokud je vybrán typ faktury, ve kterém je e-mail uveden. Pokud je vyplněna e-mailová adresa v číselníku Pracovníků, má tato přednost. Pokud není e-mailová adresa vyplněna ani v číselníku pracovníků ani v seznamu uživatelů, potom se použije e-mailová adresa z parametru Základní nastavení firmy.

Cesta+e-razítko/e-podpis - cesta k razítku a podpisu, tiskne se do faktury. Pokud je vyplněna cesta pro podpis a razítko v číselníku Pracovníků, má tato přednost.

Blokovot uživatele od - datum od kdy uživatel nemá mít přístup do programu.

ExSQL, ImSQL - speciální tlačítka pro export nebo import práv přes server SQL pro vzdálený přístup

Z číselníku uživatelů se vybere ten, pro koho se založí práva přístupu. Na aktuálním řádku se přepne na záložku Práva.

Záložka Práva

Použije se tlačítko

1. Výběr zákazníka

Nabídne se seznam zákazníků programu (to je firem), do kterých bude mít uživatel přístup. Správce zvolí všechny. Pro jednotlivé uživatele nezapomeňte na zákazníka Příklad. (Pro případné zkoušení v pokusné firmě).

Každému z uživatelů lze nastavit jiná práva pro každou firmu. V případě, že vyplníte v některém právu označení zákazníka, pak toto právo platí danému uživateli pouze pro zadaného zákazníka. V jiném zákazníkovi žádné právo nemá.

Správce programu by měl mít přístup do všech firem, proto je třeba zvolit -

Pro ukončení výběru se použije tlačítko

2. Výběr agendy

V položce Agenda se vyberou agendy, do kterých bude mít uživatel přístup. V jednom zákazníkovi může mít uživatel nastavena práva i jen pro vybrané agendy.

Správce programu by měl mít přístup do všech agend, proto je třeba zvolit -

Pro ukončení výběru se použije tlačítko

3. Výběr práv

V položce Práva se vybere, jaká práva budou uživateli přidělena.

Správce programu by měl mít přidělená všechna práva, proto je třeba zvolit -

  • R – čtení a prohlížení, uživatel smí pouze číst, nesmí měnit data
  • W – opravy dat
  • A – vkládání dat
  • D – rušení vět
  • M – mazání vět
  • T -tisk

Pro ukončení výběru se použije tlačítko

Po seznamu Agenda a Práva se pohybujeme pomocí směrových kláves. Můžeme vybírat jeden nebo více řádků. Pomocí klávesy Enter nebo myší můžeme vybrat položky pro výběr. Vybraný řádek je potom kontrastně označen. Vpravo je umístěn svislý posuvník pro pohyb myší.

  • Označení řádku - levé tlačítko myši nebo klávesa Enter.

  • Označení více řádků – klávesa Ctrl+levé tlačítko myši.

Označení více řádků po sobě – klávesa Shift+levé tlačítko myši nebo Shift+Ż.

Práva správce:

Práva podle uživatele

Tlačítko -

Je možné použít i tlačítko Kopie práv , které podle vybraného uživatele založí stejná práva pro dalšího uživatele.

Heslo uživatele

Přihlášený uživatel má možnost si zadat své heslo pomoci tlačítka Změnit heslo při ukončení programu. Heslo si každý uživatel může nastavit sám.

Ukončení programu

Každý z uživatelů se pak při spuštění programu musí přihlásit pod svým jménem a případně svým heslem.

Přihlášený uživatel má možnost si zadat své heslo pomoci tlačítka - Změnit heslo při ukončení programu.

Konec agendy Práva přístupu tlačítko [image], klávesa Esc nebo [image].

Pravidelná změna hesla

Je možnost pravidelně měnit přístupové heslo. Parametry:

  • Povinné používání hesla – ANO

  • Délka platnosti hesla v měsících – zapíše se počet měsíců platnosti hesla

U každého uživatele se v agendě Práva přístupu nastaví datum do položky Platnost hesla do.

Když vyprší uživateli platnost hesla, zobrazí se při spuštění programu výzva ke změně hesla.

Záložka Žurnál

Záložka Žurnál zobrazuje uživatele, kteří s programem právě pracuje: kód jméno a čas, kdy se uživatel přihlásil.

Při volbě [image] se zobrazí všichni uživatelé, kteří současně s programem pracují.

Tisk Přehledu práv

Přehled práv přístupu je možné vytisknout podle zvoleného filtru.

Tiskové menu [image] - Přehled práv.

Zrušení práv přístupu

Aby byla zachována minulost, je výhodnější pro zrušení práv přístupu využít položku Blokovat od.

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 02.06.2023


MANW propojení s DMS - DMS

DMS
MANW propojení s DMS
Seznam kapitol

MANW propojení s DMS

Ve vydaných a v přijatých fakturách MANW je možné přikládat k fakturám dokumenty, fotky a obrázky z DMS (párovat dokumenty s doklady) a prohlížet k dokladu připárované dokumenty. V Příkazech k úhradě lze prohlížet dokumenty z DMS připojené k fakturám/dobropisům zařazeným do příkazu.

Počáteční technické nastavení propojení programů MANW a DMS provede pracovník Com-Sys software.

Párování dokumentů k dokladům z MANW

Tlačítkem [image] na kartě faktury otevřete formulář na párování dokumentů z DMS.

V levé části naleznete seznam dokumentů z DMS, které jsou příslušného typu (přijatá faktura nebo vydaná faktura) a nejsou spárované s žádným dokladem v MANW.

Uprostřed je náhle na v seznamu označený dokument.

Vlevo dole jsou zobrazeny podrobnější informace o dokumentu z DMS.

Tlačítka [image] - filtr omezující počet zobrazených souborů

- znovu načte obsah zvolené složky (př. přibyly v ní obrázky).

Tlačítky [image] můžete přecházet mezi agendami, kam zrovna potřebujete aktuálně zpracovávaný dokument přiložit.

- přiloží soubor ke kartě dokladu, kterou máta zobrazenou. Pokud dokument ze seznamu přiložíte k dokladu, pak se označí zeleně a při dalším otevření seznamu se již neobjeví (nesplňuje podmínky, protože je již spárovaný s dokladem).

- založí nový doklad a přiloží k němu soubor, který je právě v seznamu označený (na kterém stojíte).

- založí nový doklad, a vyplní ho podle informací obsažených v QR kódu.

Tiskové menu

V tiskovém menu najdete tlačítko [image], které vytvoří pdf soubor jakéhokoli reportu a uloží se do dokumentů v DMS.

V agendách Vydané faktury, Přijaté faktury, Banka a Příkazy k úhradě se tlačítkem [image] vytvořený pdf soubor přiloží k označenému dokladu = je v DMS spárovaný s tímto dokladem. Je možné ho pak k dokladu zobrazit v DMS a v MANW př. v záložce Foto + dokument nebo při prohlížení připojených souborů ( [image]).

V ostatních agendách se tlačítkem [image] vytvořený pdf soubor uloží do DMS a otevře se formulář, který umožňuje doplnění podrobností do DMS. Dokument je spárovaný s dokladem, který byl označen, když se použilo tlačítko [image].

Párování dokumentů, nastavení nového stavu dokumentu v tomto formuláři atd. je omezeno tím, zda na tuto činnost má daný uživatel nastavená práva v DMS.

Záložka Foto + dokument

Tato záložka slouží k přiložení příloh a nahlíží do dokumentů připojených k dokladu v DMS.

Do této záložky je v MANW možné přikládat další soubory.

• obrázky (typ souboru JPG, BMP, TIFF, GIF).

• související dokumenty (ve formátu DOC, XLS, TXT, PDF, RAR, ZIP apod.)

Je možné také soubory přetáhnout z MS OFFICE Outlook přetáhnout.

Klávesa [image] zobrazí dialog pro výběr připojovaného souboru. Vybere se soubor, který je uložený na disku.

A po potvrzení se zařadí se do záložky.

Souboru lze dopsat popis, k dispozici je jeden řádek.

Jsou použita obvyklá obrázková tlačítka

Dvojklik na obrázku otevře dokument.

Tlačítko [image] také otevře dokument.

Přetáhnutí dokumentů

Tlačítko

Myší se přesuneme na požadovaný vyhledaný soubor.

Stiskne se podrží tlačítko na myši, aby byl soubor „uchopen“.

„Přetáhne“ se na požadované místo - záložku Foto+dokument.

Poté se „Pustí“ soubor uvolněním tlačítka.

Tlačítko [image] otevře Microsoft Photo Editor, ve kterém se dají fota zpracovávat.

Prohlížení připojených souborů

Pro zrychlení a zjednodušení kontroly, zda je doklad správně zaúčtován, zda mu nechybí některá z náležitostí daňového dokladu atd. máte možnost tlačítkem [image].

Tato funkce také nahlíží do dokumentů připojených k dokladu v DMS, stejně jako záložka Foto + Dokument.

Mezi doklady příslušnými přílohami pak můžete rychle přecházet [image] [image] v dolní části karty dokladu.

Pokud je u dané položky příloh víc, zobrazí se tlačítka [image], kterými můžete mezi přílohami přecházet.

Tlačítko [image] - Prohlížený soubor zůstává i pokud dál pracujete a přepínáte v programu na jiné zaúčtované doklady atp.

Pokud tlačítko [image] zmáčknete změní se na [image] = zobrazuje se soubor, který je přiložený k právě prohlíženému dokladu-> při přecházení mezi doklady v účetním deníku [image] [image] se mění.

Prohlížet dokumenty připojené k dokladu v DMS lze také v agendě příkazy k úhradě.

Tlačítka [image] umožňující otevřít označený doklad zařazený v příkazu k úhradě v příslušné agendě.

- otevře kartu adresy organizace, které platím

- otevře kartu označené faktury nebo dobropisu

Označení dokladů s připojenými dokumenty

V agendách Vydané faktury, Přijaté faktury, Příkazy k úhradě, Banka a Pokladna jsou na záložce seznam zeleně podbarvená čísla dokladů, které mají připojený nějaký dokument.

Zobrazení přiložených dokumentů:

Vydané faktury - záložka Foto+Dokument, tlačítko

Přijaté faktury - záložka Foto+Dokument, tlačítko

Příkazy k úhradě - tlačítka [image] a [image] (číslo zobrazuje počet přiložených dokumentů)

Banka - tlačítko

Pokladna - záložka Foto+Dokument, tlačítko

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


PUW - nahlížení dokumentů z DMS - DMS

DMS
PUW - nahlížení dokumentů z DMS
Seznam kapitol

PUW - nahlížení dokumentů z DMS

V účetním deníku programu PUW je možné prolížet dokumenty, které má daný doklad přiložené v programu DMS.

PUW nastavení

Počáteční technické nastavení propojení programů PUW a DMS provede pracovník Com-Sys software.

Natavení parametru foto_na_sql= Ano

Je nutné mít vyplněné pole Agedna v číselníku "Řady dokladů". Lze hromadně doplnit podle Company Manageru.

Horní lištové menu Číselníky -> Řady dokladů -> tlačítko

PUW zobrazení dokumentů z DMS

V Účetním deníku pak fungují všechny činnosti práce s přiloženými dokumenty viz červený rámeček.

Dokumenty, které jsou k danému dokladu připojeny v Company Manageru (MANW), lze pak zobrazit i u jeho zaúčtování v podvojém účetnictví (PUW).

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


Mazat zrušené věty - DMS

DMS
Mazat zrušené věty
Seznam kapitol

Mazat zrušené věty

Související témata

Tlačítka v programu |
© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 31.05.2023


Nastavení parametrů - DMS

DMS
Nastavení parametrů
Seznam kapitol

Nastavení parametrů

© Ing. Zdeněk Krejčí Com-Sys Software, 1990-2023 • Poslední úprava: 05.06.2023


  • Simple
  • Detailed
  • DMS
    • Možnosti programu DMS
    • Hlavní obrazovka
    • Instalace programu
      • Instalace programu
      • Registrace
      • První spuštění programu
    • Ovládací prvky
      • Tlačítka v pravém horním rohu
      • Horní lištové menu
        • Menu tabulka
        • F3 - Pořadí
        • F7 - Hledej
        • F9 - Uživatelské výpisy
          • Uživatelské výpisy - režim Tisk
          • Uživatelské výpisy - režim Návrh
            • Uživatelské výpisy - Select - SQL
            • Uživatelské výpisy - Položky
            • Uživatelské výpisy - Filtr
            • Uživatelské výpisy - formát výstupu
        • Tisk/export tabulky podle gridu ALT+ F9
        • Uživatelské výpisy formát výstupu
        • Nápověda - F1
        • Nápověda
        • Menu Služby
      • Posuvníky
      • Tlačítka v programu
      • Seznam
      • Textová pole
      • Rozbalovací seznam
      • Tabulka
      • Zobrazení tabulky
      • Předvolba
      • Přepínače
      • Obrázková tlačítka
      • Klávesy pro ovládání
        • Přehledná tabulka tlačítek a kláves
      • Záložky
      • Podrobný filtr
      • Hromadný výběr řádků
    • Zavedení firmy
      • Založení nového zákazníka
      • Výběr zákazníka
      • Vyplnění číselníků
    • Pořízení
    • Dokumenty
    • Náhledy do agedny s dokumenty
    • Číselníky
    • Oprávnění zobrazení dokumentů
    • Export vybraných dokumentů do souboru
    • Servis
      • Nastavení parametrů
      • Práva přístupu
    • MANW propojení s DMS
    • PUW - nahlížení dokumentů z DMS